aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql90-plpython/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/postgresql90-plpython/Makefile')
-rw-r--r--databases/postgresql90-plpython/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/databases/postgresql90-plpython/Makefile b/databases/postgresql90-plpython/Makefile
index 678cc27dc5a6..b8b4ad02dd93 100644
--- a/databases/postgresql90-plpython/Makefile
+++ b/databases/postgresql90-plpython/Makefile
@@ -14,15 +14,13 @@ MASTERDIR= ${.CURDIR}/../postgresql${WANT_PGSQL_VER}-server
WANT_PGSQL_VER?= 90
USE_PYTHON?= yes
-PYTHON_MAJOR_VER= ${PYTHON_VER:R}
CONFIGURE_ARGS= --with-python
-PLIST_SUB= PYTHON_MAJOR_VER=${PYTHON_MAJOR_VER}
COMPONENT= -plpython
-.if ${PYTHON_MAJOR_VER} == 3
-PLIST_SUB+= PYTHON3=""
+.if defined(PYTHON_VER) && ${PYTHON_VER:R} == 3
+PLIST_SUB+= PYTHON2="@comment " PYTHON3=""
.else
-PLIST_SUB+= PYTHON3="@comment "
+PLIST_SUB+= PYTHON2="" PYTHON3="@comment "
.endif
BUILD_DIRS= src/backend src/pl/plpython