aboutsummaryrefslogtreecommitdiff
path: root/databases/py-PyGreSQL/files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/py-PyGreSQL/files/Makefile')
-rw-r--r--databases/py-PyGreSQL/files/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/databases/py-PyGreSQL/files/Makefile b/databases/py-PyGreSQL/files/Makefile
index 291913ae6ac5..a5a0f5988bd7 100644
--- a/databases/py-PyGreSQL/files/Makefile
+++ b/databases/py-PyGreSQL/files/Makefile
@@ -1,12 +1,14 @@
.SUFFIXES: .py .pyc
-all: pgmodule.so pgext.pyc pgtools.pyc
+SITE_PACKAGES=${PREFIX}/lib/python1.5/site-packages
+
+all: _pgmodule.so pg.pyc pgtools.pyc
install:
- @${MKDIR} ${PREFIX}/lib/site-python
- ${BSD_INSTALL_PROGRAM} pgmodule.so ${PREFIX}/lib/site-python
- ${BSD_INSTALL_DATA} pgext.py pgext.pyc pgtools.py pgtools.pyc \
- ${PREFIX}/lib/site-python
+ @${MKDIR} ${SITE_PACKAGES}
+ ${BSD_INSTALL_PROGRAM} _pgmodule.so ${SITE_PACKAGES}
+ ${BSD_INSTALL_DATA} pg.py pg.pyc pgtools.py pgtools.pyc \
+ ${SITE_PACKAGES}
clean:
rm -f *.so *.o *.pyc pgtools.py
@@ -14,7 +16,7 @@ clean:
pgtools.py: tutorial/pgtools.py
${LN} -fs ${.ALLSRC} ${.TARGET}
-pgmodule.so: pgmodule.o
+_pgmodule.so: pgmodule.o
${LD} -Bshareable -lc_r -L${PREFIX}/lib/python1.5/config -lpython1.5 \
-L${PREFIX}/pgsql/lib -lpq ${.ALLSRC} -o ${.TARGET}