aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlite2/files
diff options
context:
space:
mode:
Diffstat (limited to 'databases/sqlite2/files')
-rw-r--r--databases/sqlite2/files/example.tcl14
-rw-r--r--databases/sqlite2/files/patch-makefile206
-rw-r--r--databases/sqlite2/files/pkgIndex.tcl1
3 files changed, 0 insertions, 221 deletions
diff --git a/databases/sqlite2/files/example.tcl b/databases/sqlite2/files/example.tcl
deleted file mode 100644
index 765c3f9ba715..000000000000
--- a/databases/sqlite2/files/example.tcl
+++ /dev/null
@@ -1,14 +0,0 @@
-package require sqlite
-
-if {$argc!=2} {
- puts stderr "Usage: %s DATABASE SQL-STATEMENT"
- exit 1
-}
-sqlite db [lindex $argv 0]
-db eval [lindex $argv 1] x {
- foreach v $x(*) {
- puts "$v = $x($v)"
- }
- puts ""
-}
-db close
diff --git a/databases/sqlite2/files/patch-makefile b/databases/sqlite2/files/patch-makefile
deleted file mode 100644
index a3739872b3c1..000000000000
--- a/databases/sqlite2/files/patch-makefile
+++ /dev/null
@@ -1,206 +0,0 @@
-*** ../../tmp/sqlite/Makefile.in Sat May 17 04:26:29 2003
---- Makefile.in Sun Jun 8 18:54:50 2003
-***************
-*** 33,39 ****
- prefix = @prefix@
- exec_prefix = @exec_prefix@
- INSTALL = @INSTALL@
-! LIBTOOL = ./libtool
-
- # Compiler options needed for programs that use the TCL library.
- #
---- 33,39 ----
- prefix = @prefix@
- exec_prefix = @exec_prefix@
- INSTALL = @INSTALL@
-! LIBTOOL = %%LIBTOOL%%
-
- # Compiler options needed for programs that use the TCL library.
- #
-***************
-*** 166,172 ****
- | awk '{print $$5,$$6}' >last_change
-
- libsqlite.la: $(LIBOBJ)
-! $(LIBTOOL) $(TCC) -o libsqlite.la $(LIBOBJ) -rpath $(exec_prefix)/lib
-
- libtclsqlite.la: tclsqlite.lo libsqlite.la
- $(LIBTOOL) $(TCC) -o libtclsqlite.la tclsqlite.lo \
---- 166,172 ----
- | awk '{print $$5,$$6}' >last_change
-
- libsqlite.la: $(LIBOBJ)
-! $(LIBTOOL) $(TCC) -o libsqlite.la $(LIBOBJ) -rpath $(exec_prefix)/lib -version-info 2:0:0
-
- libtclsqlite.la: tclsqlite.lo libsqlite.la
- $(LIBTOOL) $(TCC) -o libtclsqlite.la tclsqlite.lo \
-***************
-*** 338,404 ****
- ./testfixture $(TOP)/test/quick.test
-
- index.html: $(TOP)/www/index.tcl last_change
-! tclsh $(TOP)/www/index.tcl `cat $(TOP)/VERSION` >index.html
-
- sqlite.html: $(TOP)/www/sqlite.tcl
-! tclsh $(TOP)/www/sqlite.tcl >sqlite.html
-
- c_interface.html: $(TOP)/www/c_interface.tcl
-! tclsh $(TOP)/www/c_interface.tcl >c_interface.html
-
- changes.html: $(TOP)/www/changes.tcl
-! tclsh $(TOP)/www/changes.tcl >changes.html
-
- lang.html: $(TOP)/www/lang.tcl
-! tclsh $(TOP)/www/lang.tcl >lang.html
-
- vdbe.html: $(TOP)/www/vdbe.tcl
-! tclsh $(TOP)/www/vdbe.tcl >vdbe.html
-
- arch.html: $(TOP)/www/arch.tcl
-! tclsh $(TOP)/www/arch.tcl >arch.html
-
- arch.png: $(TOP)/www/arch.png
- cp $(TOP)/www/arch.png .
-
- opcode.html: $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c
-! tclsh $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c >opcode.html
-
- mingw.html: $(TOP)/www/mingw.tcl
-! tclsh $(TOP)/www/mingw.tcl >mingw.html
-
- tclsqlite.html: $(TOP)/www/tclsqlite.tcl
-! tclsh $(TOP)/www/tclsqlite.tcl >tclsqlite.html
-
- speed.html: $(TOP)/www/speed.tcl
-! tclsh $(TOP)/www/speed.tcl >speed.html
-
- faq.html: $(TOP)/www/faq.tcl
-! tclsh $(TOP)/www/faq.tcl >faq.html
-
- formatchng.html: $(TOP)/www/formatchng.tcl
-! tclsh $(TOP)/www/formatchng.tcl >formatchng.html
-
- conflict.html: $(TOP)/www/conflict.tcl
-! tclsh $(TOP)/www/conflict.tcl >conflict.html
-
- download.html: $(TOP)/www/download.tcl
-! tclsh $(TOP)/www/download.tcl >download.html
-
- omitted.html: $(TOP)/www/omitted.tcl
-! tclsh $(TOP)/www/omitted.tcl >omitted.html
-
- datatypes.html: $(TOP)/www/datatypes.tcl
-! tclsh $(TOP)/www/datatypes.tcl >datatypes.html
-
- quickstart.html: $(TOP)/www/quickstart.tcl
-! tclsh $(TOP)/www/quickstart.tcl >quickstart.html
-
- fileformat.html: $(TOP)/www/fileformat.tcl
-! tclsh $(TOP)/www/fileformat.tcl >fileformat.html
-
- nulls.html: $(TOP)/www/nulls.tcl
-! tclsh $(TOP)/www/nulls.tcl >nulls.html
-
-
- # Files to be published on the website.
---- 338,404 ----
- ./testfixture $(TOP)/test/quick.test
-
- index.html: $(TOP)/www/index.tcl last_change
-! $(TCLSH) $(TOP)/www/index.tcl `cat $(TOP)/VERSION` >index.html
-
- sqlite.html: $(TOP)/www/sqlite.tcl
-! $(TCLSH) $(TOP)/www/sqlite.tcl >sqlite.html
-
- c_interface.html: $(TOP)/www/c_interface.tcl
-! $(TCLSH) $(TOP)/www/c_interface.tcl >c_interface.html
-
- changes.html: $(TOP)/www/changes.tcl
-! $(TCLSH) $(TOP)/www/changes.tcl >changes.html
-
- lang.html: $(TOP)/www/lang.tcl
-! $(TCLSH) $(TOP)/www/lang.tcl >lang.html
-
- vdbe.html: $(TOP)/www/vdbe.tcl
-! $(TCLSH) $(TOP)/www/vdbe.tcl >vdbe.html
-
- arch.html: $(TOP)/www/arch.tcl
-! $(TCLSH) $(TOP)/www/arch.tcl >arch.html
-
- arch.png: $(TOP)/www/arch.png
- cp $(TOP)/www/arch.png .
-
- opcode.html: $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c
-! $(TCLSH) $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c >opcode.html
-
- mingw.html: $(TOP)/www/mingw.tcl
-! $(TCLSH) $(TOP)/www/mingw.tcl >mingw.html
-
- tclsqlite.html: $(TOP)/www/tclsqlite.tcl
-! $(TCLSH) $(TOP)/www/tclsqlite.tcl >tclsqlite.html
-
- speed.html: $(TOP)/www/speed.tcl
-! $(TCLSH) $(TOP)/www/speed.tcl >speed.html
-
- faq.html: $(TOP)/www/faq.tcl
-! $(TCLSH) $(TOP)/www/faq.tcl >faq.html
-
- formatchng.html: $(TOP)/www/formatchng.tcl
-! $(TCLSH) $(TOP)/www/formatchng.tcl >formatchng.html
-
- conflict.html: $(TOP)/www/conflict.tcl
-! $(TCLSH) $(TOP)/www/conflict.tcl >conflict.html
-
- download.html: $(TOP)/www/download.tcl
-! $(TCLSH) $(TOP)/www/download.tcl >download.html
-
- omitted.html: $(TOP)/www/omitted.tcl
-! $(TCLSH) $(TOP)/www/omitted.tcl >omitted.html
-
- datatypes.html: $(TOP)/www/datatypes.tcl
-! $(TCLSH) $(TOP)/www/datatypes.tcl >datatypes.html
-
- quickstart.html: $(TOP)/www/quickstart.tcl
-! $(TCLSH) $(TOP)/www/quickstart.tcl >quickstart.html
-
- fileformat.html: $(TOP)/www/fileformat.tcl
-! $(TCLSH) $(TOP)/www/fileformat.tcl >fileformat.html
-
- nulls.html: $(TOP)/www/nulls.tcl
-! $(TCLSH) $(TOP)/www/nulls.tcl >nulls.html
-
-
- # Files to be published on the website.
-***************
-*** 432,444 ****
-
- install: sqlite libsqlite.la sqlite.h
- $(INSTALL) -d $(exec_prefix)/lib
-! $(LIBTOOL) $(INSTALL) libsqlite.la $(exec_prefix)/lib
- $(INSTALL) -d $(exec_prefix)/bin
-! $(LIBTOOL) $(INSTALL) sqlite $(exec_prefix)/bin
- $(INSTALL) -d $(prefix)/include
- $(INSTALL) -m 0644 sqlite.h $(prefix)/include
-! $(INSTALL) -d $(exec_prefix)/lib/pkgconfig; \
-! $(INSTALL) -m 0644 sqlite.pc $(exec_prefix)/lib/pkgconfig; \
-
- clean:
- rm -f *.lo *.la *.o sqlite libsqlite.la sqlite.h opcodes.*
---- 432,448 ----
-
- install: sqlite libsqlite.la sqlite.h
- $(INSTALL) -d $(exec_prefix)/lib
-! $(INSTALL) .libs/libsqlite.a $(prefix)/lib
-! $(INSTALL) .libs/libsqlite.so $(prefix)/lib
-! $(INSTALL) .libs/libsqlite.so.2 $(prefix)/lib
- $(INSTALL) -d $(exec_prefix)/bin
-! $(INSTALL) .libs/sqlite $(exec_prefix)/bin
- $(INSTALL) -d $(prefix)/include
- $(INSTALL) -m 0644 sqlite.h $(prefix)/include
-!
-! install-tcl: libtclsqlite.la
-! $(INSTALL) -d $(prefix)/lib/sqlite
-! $(INSTALL) .libs/libtclsqlite.so $(prefix)/lib/sqlite
-
- clean:
- rm -f *.lo *.la *.o sqlite libsqlite.la sqlite.h opcodes.*
diff --git a/databases/sqlite2/files/pkgIndex.tcl b/databases/sqlite2/files/pkgIndex.tcl
deleted file mode 100644
index d96e27a1bc55..000000000000
--- a/databases/sqlite2/files/pkgIndex.tcl
+++ /dev/null
@@ -1 +0,0 @@
-package ifneeded sqlite 0.0 [list load [file join $dir libtclsqlite.so] sqlite]