aboutsummaryrefslogtreecommitdiff
path: root/deskutils/etoile-panekit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/etoile-panekit/Makefile')
-rw-r--r--deskutils/etoile-panekit/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/deskutils/etoile-panekit/Makefile b/deskutils/etoile-panekit/Makefile
new file mode 100644
index 000000000000..0080cb948fbf
--- /dev/null
+++ b/deskutils/etoile-panekit/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: etoile-panekit
+# Date created: 22 Dec 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= panekit
+PORTVERSION= 0.1.${SNAPSHOT}
+CATEGORIES= deskutils
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://people.freebsd.org/~%%SUBDIR%%/distfiles/
+MASTER_SITE_SUBDIR= dinoex
+PKGNAMEPREFIX= etoile-
+DISTNAME= Etoile-${SNAPSHOT}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Framework which provides flexible pane window in GNUstep
+
+USE_BZIP2= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+DEFAULT_LIBVERSION= 0.1
+USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+
+SNAPSHOT= 20061221
+WRKSRC= ${WRKDIR}/Etoile/
+USE_GNUSTEP_MAKE_DIRS+= Frameworks/PaneKit
+
+.include <bsd.port.mk>