aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnome-initial-setup/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/gnome-initial-setup/Makefile')
-rw-r--r--deskutils/gnome-initial-setup/Makefile53
1 files changed, 20 insertions, 33 deletions
diff --git a/deskutils/gnome-initial-setup/Makefile b/deskutils/gnome-initial-setup/Makefile
index 86c01ab5b774..2341a8347bfc 100644
--- a/deskutils/gnome-initial-setup/Makefile
+++ b/deskutils/gnome-initial-setup/Makefile
@@ -1,45 +1,32 @@
# Created by: Gustau Perez <gustau.perez@gmail.com>
PORTNAME= gnome-initial-setup
-PORTVERSION= 3.18.0
-PORTREVISION= 9
+PORTVERSION= 41.0
CATEGORIES= deskutils gnome
-MASTER_SITES= GNOME
+MASTER_SITES= GNOME/sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+)\..*/\1/}
DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
-COMMENT= First boot setup tool for GNOME 3
-
-BUILD_DEPENDS= gnome-autogen.sh:devel/gnome-common \
- gdm>=3.0.0:x11/gdm
-LIB_DEPENDS= libgoa-1.0.so:net/gnome-online-accounts \
- libaccountsservice.so:sysutils/accountsservice \
- libpwquality.so:security/libpwquality \
- libgweather-3.so:net/libgweather
-RUN_DEPENDS= gdm>=3.0.0:x11/gdm
-
-PORTSCOUT= limitw:1,even
-
-USES= autoreconf compiler:c++11-lib gettext gmake gnome libtool \
- pathfix pkgconfig tar:xz
-USE_GNOME= gnomedesktop3 gnomeprefix gtk30 intlhack
-USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
+COMMENT= First boot setup tool for GNOME
+
+BUILD_DEPENDS= gdm>=3.0.0:x11/gdm \
+ gnome-autogen.sh:devel/gnome-common \
+ krb5>0:security/krb5
+LIB_DEPENDS= libaccountsservice.so:sysutils/accountsservice \
+ libgoa-1.0.so:net/gnome-online-accounts \
+ libgweather-3.so:net/libgweather \
+ libpwquality.so:security/libpwquality
+RUN_DEPENDS= gdm>=3.0.0:x11/gdm \
+ krb5>0:security/krb5
+
+USES= compiler:c++11-lib gnome meson pathfix pkgconfig tar:xz
+USE_GNOME= gnomedesktop3 gtk30 intlhack
INSTALLS_ICONS= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= KERBEROS
-OPTIONS_DEFAULT=KERBEROS
+MESON_ARGS= -Dcheese=disabled \
+ -Dparental_controls=disabled \
+ -Dsystemd=false
-.include <bsd.port.options.mk>
-
-.if !${PORT_OPTIONS:MKERBEROS}
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-gnome-initial-setup_gis-account-page.c
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|krb5/krb5.h|krb5.h|g' \
- ${WRKSRC}/gnome-initial-setup/pages/account/um-realm-manager.c
+PORTSCOUT= limitw:1,even
.include <bsd.port.mk>