aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnome-shell-extension-audio-output-switcher/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/gnome-shell-extension-audio-output-switcher/Makefile')
-rw-r--r--deskutils/gnome-shell-extension-audio-output-switcher/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/deskutils/gnome-shell-extension-audio-output-switcher/Makefile b/deskutils/gnome-shell-extension-audio-output-switcher/Makefile
index 49edf2113ddc..8646df672c30 100644
--- a/deskutils/gnome-shell-extension-audio-output-switcher/Makefile
+++ b/deskutils/gnome-shell-extension-audio-output-switcher/Makefile
@@ -1,9 +1,9 @@
# Created by: Gustau Perez i Querol <gustau.perez@gmail.com>
# $FreeBSD$
-# $MCom: ports/trunk/deskutils/gnome-shell-extension-audio-output-switcher/Makefile 19693 2014-05-26 08:54:39Z gusi $
PORTNAME= gnome-shell-extension-audio-output-switcher
PORTVERSION= 0.0.0.20140520
+PORTREVISION= 1
CATEGORIES= deskutils gnome
DIST_SUBDIR= gnome3
@@ -15,7 +15,7 @@ BUILD_DEPENDS= gnome-shell>=0:${PORTSDIR}/x11/gnome-shell \
RUN_DEPENDS= gnome-shell>=0:${PORTSDIR}/x11/gnome-shell \
gsettings-desktop-schemas>=3.12.0:${PORTSDIR}/devel/gsettings-desktop-schemas
-WRKSRC= ${WRKDIR}/anduchs-audio-output-switcher-2bec66d
+WRKSRC= ${WRKDIR}/anduchs-audio-output-switcher-${GH_COMMIT}
USES= gettext gmake pkgconfig tar:xz
USE_GNOME= glib20
@@ -24,14 +24,18 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
GH_ACCOUNT= anduchs
-GH_TAGNAME= 2bec66de5e
-GH_COMMIT= 2bec66de5e
+GH_TAGNAME= 2bec66d
+GH_COMMIT= 2bec66d
GH_PROJECT= audio-output-switcher
PKGMESSAGE= ../gnome-shell-extra-extensions/pkg-message.slaves
NO_BUILD= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|3.12"|3.12","3.14"|g' \
+ ${WRKSRC}/metadata.json
+
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/share/gnome-shell/extensions/audio-output-switcher@anduchs
@(cd ${WRKSRC} && ${CP} -pPR * \