aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gtweakui
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/gtweakui')
-rw-r--r--deskutils/gtweakui/Makefile24
-rw-r--r--deskutils/gtweakui/distinfo2
-rw-r--r--deskutils/gtweakui/files/patch-Makefile.in43
-rw-r--r--deskutils/gtweakui/pkg-descr5
-rw-r--r--deskutils/gtweakui/pkg-plist18
5 files changed, 92 insertions, 0 deletions
diff --git a/deskutils/gtweakui/Makefile b/deskutils/gtweakui/Makefile
new file mode 100644
index 000000000000..7b8f9e4e807e
--- /dev/null
+++ b/deskutils/gtweakui/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: gTweakUI
+# Date Created: 17 June 2004
+# Whom: Sergey Akifyev <asa@gascom.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gTweakUI
+PORTVERSION= 0.0.6
+CATEGORIES= deskutils gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gtweakui
+DIST_SUBDIR= gnome2
+
+MAINTAINER= asa@gascom.ru
+COMMENT= A collection of simple dialogs as a front end to GConf
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_GNOME= gnomehack gnomeprefix libgnomeui gconf2 libglade2
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/deskutils/gtweakui/distinfo b/deskutils/gtweakui/distinfo
new file mode 100644
index 000000000000..513440e44f19
--- /dev/null
+++ b/deskutils/gtweakui/distinfo
@@ -0,0 +1,2 @@
+MD5 (gnome2/gTweakUI-0.0.6.tar.bz2) = 92a0f0eee8a43e0a158329ffa0465411
+SIZE (gnome2/gTweakUI-0.0.6.tar.bz2) = 182120
diff --git a/deskutils/gtweakui/files/patch-Makefile.in b/deskutils/gtweakui/files/patch-Makefile.in
new file mode 100644
index 000000000000..bc4cc74d0ef0
--- /dev/null
+++ b/deskutils/gtweakui/files/patch-Makefile.in
@@ -0,0 +1,43 @@
+--- Makefile.in.orig Thu Jun 17 15:44:56 2004
++++ Makefile.in Thu Jun 17 15:45:47 2004
+@@ -39,9 +39,6 @@
+ AMDEP_FALSE = @AMDEP_FALSE@
+ AMDEP_TRUE = @AMDEP_TRUE@
+ AMTAR = @AMTAR@
+-AUTOCONF = @AUTOCONF@
+-AUTOHEADER = @AUTOHEADER@
+-AUTOMAKE = @AUTOMAKE@
+ AWK = @AWK@
+ CATALOGS = @CATALOGS@
+ CATOBJEXT = @CATOBJEXT@
+@@ -175,19 +172,9 @@
+
+ .SUFFIXES:
+
+-am__CONFIG_DISTCLEAN_FILES = config.status config.cache config.log \
+- configure.lineno
+-$(srcdir)/Makefile.in: Makefile.am $(top_srcdir)/configure.ac $(ACLOCAL_M4)
+- cd $(top_srcdir) && \
+- $(AUTOMAKE) --gnu Makefile
+ Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ cd $(top_builddir) && $(SHELL) ./config.status $@ $(am__depfiles_maybe)
+
+-$(top_builddir)/config.status: $(srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
+- $(SHELL) ./config.status --recheck
+-$(srcdir)/configure: $(srcdir)/configure.ac $(ACLOCAL_M4) $(CONFIGURE_DEPENDENCIES)
+- cd $(srcdir) && $(AUTOCONF)
+-
+ $(ACLOCAL_M4): configure.ac
+ cd $(srcdir) && $(ACLOCAL) $(ACLOCAL_AMFLAGS)
+
+@@ -200,10 +187,6 @@
+ stamp-h1: $(srcdir)/config.h.in $(top_builddir)/config.status
+ @rm -f stamp-h1
+ cd $(top_builddir) && $(SHELL) ./config.status config.h
+-
+-$(srcdir)/config.h.in: $(top_srcdir)/configure.ac $(ACLOCAL_M4)
+- cd $(top_srcdir) && $(AUTOHEADER)
+- touch $(srcdir)/config.h.in
+
+ distclean-hdr:
+ -rm -f config.h stamp-h1
diff --git a/deskutils/gtweakui/pkg-descr b/deskutils/gtweakui/pkg-descr
new file mode 100644
index 000000000000..7b067cd11287
--- /dev/null
+++ b/deskutils/gtweakui/pkg-descr
@@ -0,0 +1,5 @@
+A collection of simple dialogs as a front end to GConf. We will provide extra
+configuration settings for GNOME that power users have been requesting since
+the release of GNOME 2.0.
+
+WWW: http://gtweakui.sourceforge.net/
diff --git a/deskutils/gtweakui/pkg-plist b/deskutils/gtweakui/pkg-plist
new file mode 100644
index 000000000000..c629d362245d
--- /dev/null
+++ b/deskutils/gtweakui/pkg-plist
@@ -0,0 +1,18 @@
+bin/gtweakui-menus
+bin/gtweakui-session
+bin/gtweakui-nautilus
+share/gnome/gTweakUI/g.png
+share/gnome/gTweakUI/menus0.png
+share/gnome/gTweakUI/menus1.png
+share/gnome/gTweakUI/menus2.png
+share/gnome/gTweakUI/menus3.png
+share/gnome/gTweakUI/menus.glade
+share/gnome/gTweakUI/session.glade
+share/gnome/gTweakUI/nautilus.glade
+share/gnome/gTweakUI/about.glade
+share/gnome/gTweakUI/notice.glade
+share/gnome/gTweakUI/bullet.png
+share/gnome/applications/gtweakui-menus.desktop
+share/gnome/applications/gtweakui-session.desktop
+share/gnome/applications/gtweakui-nautilus.desktop
+@dirrm share/gnome/gTweakUI