aboutsummaryrefslogtreecommitdiff
path: root/deskutils/horde4-kronolith/files/pkg-deinstall.in
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/horde4-kronolith/files/pkg-deinstall.in')
-rw-r--r--deskutils/horde4-kronolith/files/pkg-deinstall.in27
1 files changed, 27 insertions, 0 deletions
diff --git a/deskutils/horde4-kronolith/files/pkg-deinstall.in b/deskutils/horde4-kronolith/files/pkg-deinstall.in
new file mode 100644
index 000000000000..896c740dd4da
--- /dev/null
+++ b/deskutils/horde4-kronolith/files/pkg-deinstall.in
@@ -0,0 +1,27 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Backup Kronolith config files, if needed.
+
+if [ x$2 != xDEINSTALL ]; then
+ exit
+fi
+
+if [ -z "${PACKAGE_BUILDING}" ]; then
+ for cf in `ls %%KRONOLITHDIR%%/config/*php`; do
+ diff -bBqw $cf $cf.dist >/dev/null 2>&1
+ case $? in
+ 0) # original config file, will be deleted by pkg-plist
+ ;;
+ 1) # config file has been updated, must be backuped
+ cp -p $cf $cf.previous
+ echo "===> Backing-up..."
+ echo "---> $cf has been saved ***"
+ echo "---> as $cf.previous ***"
+ ;;
+ *) # not found?
+ ;;
+ esac
+ done
+fi