aboutsummaryrefslogtreecommitdiff
path: root/deskutils/horde4-nag/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/horde4-nag/Makefile')
-rw-r--r--deskutils/horde4-nag/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/deskutils/horde4-nag/Makefile b/deskutils/horde4-nag/Makefile
index f3ccc17bfe69..cb9a82b04abc 100644
--- a/deskutils/horde4-nag/Makefile
+++ b/deskutils/horde4-nag/Makefile
@@ -31,7 +31,7 @@ USE_GETTEXT= yes
PLIST_SUB= NAGDIR=${LNAGDIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= NAGDIR=${NAGDIR}
REINPLACE_ARGS= -i ""
@@ -67,11 +67,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${NAGDIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${NAGDIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${NAGDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-nag.conf ${HORDE_INC}
@@ -84,6 +80,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}