aboutsummaryrefslogtreecommitdiff
path: root/devel/adabooch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/adabooch/Makefile')
-rw-r--r--devel/adabooch/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/devel/adabooch/Makefile b/devel/adabooch/Makefile
new file mode 100644
index 000000000000..cfd6f0ce3c4e
--- /dev/null
+++ b/devel/adabooch/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: adabooch
+# Date created: 21 December 2002
+# Whom: David Holm <david@realityrift.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= adabooch
+PORTVERSION= 20020602
+CATEGORIES= devel
+MASTER_SITES= http://www.adapower.net/booch/download/
+DISTNAME= bc-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= david@realityrift.com
+COMMENT= Library which provide container classes as well as powertools for Ada
+
+NO_BUILD= yes
+
+do-install:
+ @${ECHO} Installing library files
+ @${MKDIR} ${PREFIX}/lib/adabooch
+ @for i in `cat pkg-plist|grep "lib/adabooch/"|sed "s/lib\/adabooch\///"`; do \
+ ${INSTALL_DATA} ${WRKSRC}/$${i} ${PREFIX}/lib/adabooch; \
+ done
+
+ @${MKDIR} ${PREFIX}/share/adabooch
+ @${ECHO} Installing demos and tests
+ @${MKDIR} ${PREFIX}/share/adabooch/demo
+ @for i in `cat pkg-plist|grep "share/adabooch/demo/"|sed "s/share\/adabooch\/demo\///"`; do \
+ ${INSTALL_DATA} ${WRKSRC}/demo/$${i} ${PREFIX}/share/adabooch/demo; \
+ done
+
+ @${MKDIR} ${PREFIX}/share/adabooch/test
+ @for i in `cat pkg-plist|grep "share/adabooch/test/"|sed "s/share\/adabooch\/test\///"`; do \
+ ${INSTALL_DATA} ${WRKSRC}/test/$${i} ${PREFIX}/share/adabooch/test; \
+ done
+
+post-install:
+ @${ECHO}
+ @${ECHO} "The booch library has been installed into ${PREFIX}/lib/adabooch"
+ @${ECHO}
+
+.include <bsd.port.mk>