aboutsummaryrefslogtreecommitdiff
path: root/devel/bison175
diff options
context:
space:
mode:
Diffstat (limited to 'devel/bison175')
-rw-r--r--devel/bison175/Makefile36
-rw-r--r--devel/bison175/distinfo1
-rw-r--r--devel/bison175/files/patch-getargs.c14
-rw-r--r--devel/bison175/files/patch-intl::Makefile.in23
-rw-r--r--devel/bison175/files/patch-reader.c23
-rw-r--r--devel/bison175/pkg-comment1
-rw-r--r--devel/bison175/pkg-descr22
-rw-r--r--devel/bison175/pkg-plist18
8 files changed, 0 insertions, 138 deletions
diff --git a/devel/bison175/Makefile b/devel/bison175/Makefile
deleted file mode 100644
index f9c118fa8644..000000000000
--- a/devel/bison175/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-# ex:ts=8
-# Ports collection makefile for: bison
-# Date created: 27 Mar 1999
-# Whom: Jerry Hicks
-#
-# $FreeBSD$
-#
-
-PORTNAME= bison
-PORTVERSION= 1.35
-PORTREVISION= 1
-CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= bison
-
-MAINTAINER= ports@FreeBSD.org
-
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
-
-USE_BZIP2= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-included-gettext
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- MAKEINFO="makeinfo --no-split"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-
-MAN1= bison.1
-
-post-extract:
- @${RM} -f ${WRKSRC}/doc/bison.info*
-
-post-install:
- install-info ${PREFIX}/info/bison.info ${PREFIX}/info/dir
-
-.include <bsd.port.mk>
diff --git a/devel/bison175/distinfo b/devel/bison175/distinfo
deleted file mode 100644
index 52e7df9d706a..000000000000
--- a/devel/bison175/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (bison-1.35.tar.bz2) = 87de58ab8f2aa07d18b6e77e3e665850
diff --git a/devel/bison175/files/patch-getargs.c b/devel/bison175/files/patch-getargs.c
deleted file mode 100644
index 8bfc689dd9d1..000000000000
--- a/devel/bison175/files/patch-getargs.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/getargs.c.orig Wed Jan 23 05:12:17 2002
-+++ src/getargs.c Sat Feb 16 19:47:24 2002
-@@ -36,4 +36,5 @@
- int graph_flag = 0;
- int trace_flag = 0;
-+int broken_undeftoken_init;
-
- const char *skeleton = NULL;
-@@ -50,4 +51,5 @@
-
- /* Parser. */
-+ {"broken-undeftoken-init", 0, &broken_undeftoken_init, 1},
- {"skeleton", required_argument, 0, 'S'},
- {"debug", no_argument, 0, 't'},
diff --git a/devel/bison175/files/patch-intl::Makefile.in b/devel/bison175/files/patch-intl::Makefile.in
deleted file mode 100644
index adfc8cd770de..000000000000
--- a/devel/bison175/files/patch-intl::Makefile.in
+++ /dev/null
@@ -1,23 +0,0 @@
-
-$FreeBSD$
-
---- intl/Makefile.in 2002/04/30 08:12:35 1.1
-+++ intl/Makefile.in 2002/04/30 08:13:50
-@@ -52,7 +52,7 @@
- YFLAGS = --name-prefix=__gettext
-
- DEFS = -DLOCALEDIR=\"$(localedir)\" -DLOCALE_ALIAS_PATH=\"$(aliaspath)\" \
---DLIBDIR=\"$(libdir)\" -DIN_LIBINTL @DEFS@
-+-DLIBDIR=\"$(prefix)/libdata\" -DIN_LIBINTL @DEFS@
- CPPFLAGS = @CPPFLAGS@
- CFLAGS = @CFLAGS@
- LDFLAGS = @LDFLAGS@
-@@ -152,7 +152,7 @@
- else \
- : ; \
- fi
-- if test '@USE_INCLUDED_LIBINTL@' = yes; then \
-+ if test no = yes; then \
- test @GLIBC21@ != no || $(mkinstalldirs) $(DESTDIR)$(libdir); \
- temp=$(DESTDIR)$(libdir)/t-charset.alias; \
- dest=$(DESTDIR)$(libdir)/charset.alias; \
diff --git a/devel/bison175/files/patch-reader.c b/devel/bison175/files/patch-reader.c
deleted file mode 100644
index 92c21a13cc66..000000000000
--- a/devel/bison175/files/patch-reader.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/reader.c.orig Thu Feb 7 09:12:44 2002
-+++ src/reader.c Sat Feb 16 19:49:02 2002
-@@ -34,6 +34,8 @@
- #include "reader.h"
- #include "conflicts.h"
-
-+extern int broken_undeftoken_init;
-+
- typedef struct symbol_list
- {
- struct symbol_list *next;
-@@ -1978,7 +1979,10 @@
- It is always token number 2. */
- undeftoken = getsym ("$undefined.");
- undeftoken->class = token_sym;
-- undeftoken->user_token_number = 2;
-+ /* XXX ``broken_undeftoken_init'' makes Bison 1.29 bug-compatable
-+ with Bison 1.25. FreeBSD depends on this behavior when compiling
-+ EGCS-1.1.2's cc1plus. */
-+ undeftoken->user_token_number = broken_undeftoken_init ? 0 : 2;
-
- /* Read the declaration section. Copy %{ ... %} groups to
- TABLE_OBSTACK and FDEFINES file. Also notice any %token, %left,
diff --git a/devel/bison175/pkg-comment b/devel/bison175/pkg-comment
deleted file mode 100644
index a0850f8a7b1f..000000000000
--- a/devel/bison175/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-A parser generator from FSF, (mostly) compatible with Yacc
diff --git a/devel/bison175/pkg-descr b/devel/bison175/pkg-descr
deleted file mode 100644
index c968b052baf7..000000000000
--- a/devel/bison175/pkg-descr
+++ /dev/null
@@ -1,22 +0,0 @@
-Bison is a tool used to write parsers, such as the parser for GNU cc.
-It is similar to Yacc, which is included in the base FreeBSD system.
-
-The main difference between Bison and Yacc that I know of is that
-Bison supports the @N construction, which gives you access to
-the starting and ending line number and character number associated
-with any of the symbols in the current rule.
-
-Also, Bison supports the command `%expect N' which says not to mention
-the conflicts if there are N shift/reduce conflicts and no reduce/reduce
-conflicts.
-
-The differences in the algorithms stem mainly from the horrible
-kludges that Johnson had to perpetrate to make Yacc fit in a PDP-11.
-
-Also, Bison uses a faster but less space-efficient encoding for the
-parse tables (see Corbett's PhD thesis from Berkeley, "Static
-Semantics in Compiler Error Recovery", June 1985, Report No. UCB/CSD
-85/251), and more modern technique for generating the lookahead sets.
-(See "Efficient Construction of LALR(1) Lookahead Sets" by F. DeRemer
-and A. Pennello, in ACM TOPLS Vol 4 No 4, October 1982. Their
-technique is the standard one now.)
diff --git a/devel/bison175/pkg-plist b/devel/bison175/pkg-plist
deleted file mode 100644
index 60f7c9cd0ea1..000000000000
--- a/devel/bison175/pkg-plist
+++ /dev/null
@@ -1,18 +0,0 @@
-@comment $FreeBSD$
-bin/bison
-share/bison/bison.hairy
-share/bison/bison.simple
-@unexec install-info --delete %D/info/bison.info %D/info/dir
-info/bison.info
-@exec install-info %D/info/bison.info %D/info/dir
-share/locale/de/LC_MESSAGES/bison.mo
-share/locale/es/LC_MESSAGES/bison.mo
-share/locale/et/LC_MESSAGES/bison.mo
-share/locale/fr/LC_MESSAGES/bison.mo
-share/locale/it/LC_MESSAGES/bison.mo
-share/locale/ja/LC_MESSAGES/bison.mo
-share/locale/nl/LC_MESSAGES/bison.mo
-share/locale/ru/LC_MESSAGES/bison.mo
-share/locale/sv/LC_MESSAGES/bison.mo
-share/locale/tr/LC_MESSAGES/bison.mo
-@dirrm share/bison