aboutsummaryrefslogtreecommitdiff
path: root/devel/cl-infix-sbcl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cl-infix-sbcl/Makefile')
-rw-r--r--devel/cl-infix-sbcl/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/devel/cl-infix-sbcl/Makefile b/devel/cl-infix-sbcl/Makefile
new file mode 100644
index 000000000000..fb1d149925f3
--- /dev/null
+++ b/devel/cl-infix-sbcl/Makefile
@@ -0,0 +1,42 @@
+# New ports collection Makefile for: cl-infix-sbcl
+# Date created: 13 Feb 2006
+# Whom: Pedro F Giffuni
+#
+# $FreeBSD$
+
+PORTNAME= infix
+DISTVERSION= 19960628
+CATEGORIES= devel lisp
+MASTER_SITES= http://ftp.linux.org.uk/pub/lisp/cclan/ \
+ ftp://ftp.ntnu.no/pub/lisp/cclan/ \
+ http://thingamy.com/cclan/ \
+ http://www-jcsu.jesus.cam.ac.uk/ftp/pub/cclan/
+PKGNAMEPREFIX= cl-
+PKGNAMESUFFIX= -sbcl
+DISTFILES= # use installed sources from CL_LIBDIR
+EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+
+MAINTAINER= giffunip@asme.org
+COMMENT= A lisp macro to read math statements in infix notation
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/infix/infix.asd:${PORTSDIR}/devel/cl-infix \
+ ${LOCALBASE}/lib/common-lisp/asdf/sbclfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-sbcl \
+ sbcl:${PORTSDIR}/lang/sbcl
+RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/port/port.asd:${PORTSDIR}/devel/cl-port \
+ ${LOCALBASE}/lib/common-lisp/asdf/sbclfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-sbcl \
+ sbcl:${PORTSDIR}/lang/sbcl
+
+NO_CDROM= No fees or compensation can be charged
+
+do-build:
+ WRKSRC=${WRKSRC}/ FBSD_ASDF_COMPILE_PORT=t\
+ sbcl --noinform --userinit /dev/null \
+ --eval '#.(load "${LOCALBASE}/etc/asdf-init")' \
+ --eval "(asdf:oos 'asdf:compile-op :infix)" \
+ --eval "(quit)"
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/common-lisp/infix/sbclfasl
+ ${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/infix/sbclfasl/
+
+.include <bsd.port.mk>