aboutsummaryrefslogtreecommitdiff
path: root/devel/commoncpp
diff options
context:
space:
mode:
Diffstat (limited to 'devel/commoncpp')
-rw-r--r--devel/commoncpp/Makefile18
-rw-r--r--devel/commoncpp/pkg-plist6
2 files changed, 9 insertions, 15 deletions
diff --git a/devel/commoncpp/Makefile b/devel/commoncpp/Makefile
index 132988cce342..2da2aecded63 100644
--- a/devel/commoncpp/Makefile
+++ b/devel/commoncpp/Makefile
@@ -14,21 +14,15 @@ MASTER_SITE_SUBDIR= cplusplus
MAINTAINER= dyfet@gnu.org
USE_GMAKE= yes
-USE_CONFIGURE= yes
USE_LIBTOOL= yes
-#USE_AUTOCONF= yes
INSTALLS_SHLIB= yes
-#AUTOCONF= autoconf && ${PERL} -pi -e 's|-lpthread|-pthread|g ; \
-# s|l\$$ost_cv_thread_library|\$$ost_cv_thread_library|g' \
-# ${WRKSRC}/configure
-#
-# I had immense problems with autoconf generated on xBSD 4.0 where the
-# generated configure would mangle library names.
-post-extract:
- cd ${WRKSRC} ; ./configure
-# @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
-# 's|-release \$$\(LT_RELEASE\)||g'
+pre-patch:
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|-release \$$\(LT_RELEASE\)||g'
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|l\$$ost_cv_thread_library|\$$ost_cv_thread_library|g ; \
+ s|=c_r|=pthread|g' ${WRKSRC}/configure
post-install:
.if !defined(NOPORTDOCS)
diff --git a/devel/commoncpp/pkg-plist b/devel/commoncpp/pkg-plist
index 32406babee42..4ddb7d99af3b 100644
--- a/devel/commoncpp/pkg-plist
+++ b/devel/commoncpp/pkg-plist
@@ -10,15 +10,15 @@ include/cc++/serial.h
include/cc++/slog.h
include/cc++/socket.h
include/cc++/thread.h
-lib/libccio-1.2.so.0
lib/libccio.a
lib/libccio.so
-lib/libccstd-1.2.so.0
+lib/libccio.so.0
lib/libccstd.a
lib/libccstd.so
-lib/libccxx-1.2.so.0
+lib/libccstd.so.0
lib/libccxx.a
lib/libccxx.so
+lib/libccxx.so.0
share/doc/commoncpp/AtomicCounter.html
share/doc/commoncpp/BaseObject.html
share/doc/commoncpp/Body.html