aboutsummaryrefslogtreecommitdiff
path: root/devel/cssc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cssc/Makefile')
-rw-r--r--devel/cssc/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/cssc/Makefile b/devel/cssc/Makefile
new file mode 100644
index 000000000000..f65172f200d9
--- /dev/null
+++ b/devel/cssc/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: CSSC
+# Version required: 0.10beta.pl1
+# Date created: 31 Mar 1999
+# Whom: Oliver Fromme
+#
+# $Id$
+#
+
+DISTNAME= CSSC-0.10beta.pl1
+PKGNAME= cssc-0.10b.1
+CATEGORIES= devel
+MASTER_SITES= ftp://alpha.gnu.org/gnu/CSSC/
+
+MAINTAINER= olli@fromme.com
+
+GNU_CONFIGURE= yes
+MAN1= sccs.1
+
+#
+# NOTE:
+# portlint will warn about the absolute pathname "/usr/share/info/dir",
+# although it is OK in this case (see the FreeBSD Handbook, section
+# "Making a port yourself", subsection "Info files").
+#
+post-install:
+ @strip ${PREFIX}/bin/sccs
+ @for FILE in ${PREFIX}/libexec/cssc/*; do \
+ if file $$FILE | ${GREP} -q 'not stripped'; then \
+ strip $$FILE; \
+ fi; \
+ done
+ @if [ ! -f ${PREFIX}/info/dir ]; then \
+ ${SED} -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
+ fi
+ @install-info ${PREFIX}/info/cssc.info ${PREFIX}/info/dir
+
+.include <bsd.port.mk>