aboutsummaryrefslogtreecommitdiff
path: root/devel/cvsgraph/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cvsgraph/Makefile')
-rw-r--r--devel/cvsgraph/Makefile24
1 files changed, 20 insertions, 4 deletions
diff --git a/devel/cvsgraph/Makefile b/devel/cvsgraph/Makefile
index 17687b0194a1..ef6778e2315d 100644
--- a/devel/cvsgraph/Makefile
+++ b/devel/cvsgraph/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cvsgraph
-PORTVERSION= 1.1.1
+PORTVERSION= 1.1.2
CATEGORIES= devel graphics
MASTER_SITES= http://www.akhphd.au.dk/~bertho/cvsgraph/release/
@@ -17,7 +17,7 @@ LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.4:${PORTSDIR}/graphics/png
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAN1= cvsgraph.1
MAN5= cvsgraph.conf.5
@@ -25,14 +25,22 @@ MAN5= cvsgraph.conf.5
ALL_TARGET= cvsgraph
DOCDIR= share/doc/${PORTNAME}
DOCS= ChangeLog LICENCE README
+EXAMPLES= cvsgraphwrapper.php3 mkimage.php3
PLIST= ${WRKDIR}/pkg-plist
USE_AUTOCONF= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gd-inc=${LOCALBASE}/include/gd \
--with-gd-lib=${LOCALBASE}/lib \
- --with-png=${LOCALBASE} \
+ --with-jpeg-inc=${LOCALBASE}/include \
+ --with-jpeg-lib=${LOCALBASE}/lib \
+ --with-png-inc=${LOCALBASE}/include \
+ --with-png-lib=${LOCALBASE}/lib \
--with-z-inc=/usr/include \
- --with-z-lib=/usr/lib
+ --with-z-lib=/usr/lib \
+ --with-gd \
+ --with-jpeg \
+ --with-png \
+ --with-z
post-configure:
${PERL} -pi -e \
@@ -47,6 +55,10 @@ pre-install:
.for i in ${DOCS}
${ECHO} ${DOCDIR}/${i} >> ${PLIST}
.endfor
+.for i in ${EXAMPLES}
+ ${ECHO} ${PREFIX}/share/examples/${PORTNAME}/${i} >> ${PLIST}
+.endfor
+ ${ECHO} @dirrm share/examples/${PORTNAME} >> ${PLIST}
${ECHO} @dirrm ${DOCDIR} >> ${PLIST}
.endif
@@ -57,9 +69,13 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/cvsgraph.conf.5 ${PREFIX}/man/man5
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/${DOCDIR}
+ ${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
.for i in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/${DOCDIR}
.endfor
+.for i in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/examples/${PORTNAME}
+.endfor
.endif
.include <bsd.port.mk>