aboutsummaryrefslogtreecommitdiff
path: root/devel/dcmtk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/dcmtk/Makefile')
-rw-r--r--devel/dcmtk/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/dcmtk/Makefile b/devel/dcmtk/Makefile
index bf40de68def7..ae777e44aaf6 100644
--- a/devel/dcmtk/Makefile
+++ b/devel/dcmtk/Makefile
@@ -29,6 +29,12 @@ SHLIBS= dcmdata dcmdsig dcmimage dcmimgle dcmjpeg dcmnet \
SHLIBVER= ${PORTVERSION:R:R}
PLIST_SUB= SHLIBVER=${SHLIBVER}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+CFLAGS+= -fPIC
+.endif
+
post-install:
.for shlib in ${SHLIBS}
@${MV} ${PREFIX}/lib/lib${shlib}.so ${PREFIX}/lib/lib${shlib}.so.${SHLIBVER}
@@ -36,4 +42,4 @@ post-install:
.endfor
#.include "Makefile.man"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>