aboutsummaryrefslogtreecommitdiff
path: root/devel/desktop-file-utils/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/desktop-file-utils/Makefile')
-rw-r--r--devel/desktop-file-utils/Makefile40
1 files changed, 17 insertions, 23 deletions
diff --git a/devel/desktop-file-utils/Makefile b/devel/desktop-file-utils/Makefile
index 1c3002de896b..8cb9e123aa06 100644
--- a/devel/desktop-file-utils/Makefile
+++ b/devel/desktop-file-utils/Makefile
@@ -3,38 +3,32 @@
# Whom: Jean-Yves Lefort <jylefort@brutele.be>
#
# $FreeBSD$
+# $MCom: ports/devel/desktop-file-utils/Makefile,v 1.8 2007/09/07 20:22:45 mezz Exp $
#
-PORTNAME= desktop-file-utils
-PORTVERSION= 0.12
-PORTREVISION= 1
-CATEGORIES= devel
-MASTER_SITES= http://freedesktop.org/software/${PORTNAME}/releases/
+PORTNAME= desktop-file-utils
+PORTVERSION= 0.14
+CATEGORIES= devel
+MASTER_SITES= http://freedesktop.org/software/${PORTNAME}/releases/
-MAINTAINER= gnome@FreeBSD.org
-COMMENT= A couple of command line utilities for working with desktop entries
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A couple of command line utilities for working with desktop entries
-LIB_DEPENDS= popt:${PORTSDIR}/devel/popt
-
-USE_GNOME= glib20
-WANT_GNOME= yes
+USE_GNOME= glib20
+WANT_GNOME= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --without-lispdir
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" EMACS="no"
+CONFIGURE_ARGS= --without-lispdir
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" EMACS="no"
-PKGINSTALL= ${WRKDIR}/pkg-install
-PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+PKGINSTALL= ${WRKDIR}/pkg-install
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-PORT_MIMEDIRS= ${LOCALBASE}/share/applications \
- ${LOCALBASE}/share/gnome/applications
+PORT_MIMEDIRS= ${LOCALBASE}/share/applications
-MIMEDIRS= ${PORT_MIMEDIRS} \
- /usr/share/applications \
- /usr/share/gnome/applications
+MIMEDIRS= ${PORT_MIMEDIRS}
-RMDIRS= ${PORT_MIMEDIRS} \
- ${LOCALBASE}/share/gnome
+RMDIRS= ${PORT_MIMEDIRS}
post-patch:
@${SED} -e 's|%%MIMEDIRS%%|${MIMEDIRS}| ;\