aboutsummaryrefslogtreecommitdiff
path: root/devel/devhelp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/devhelp/Makefile')
-rw-r--r--devel/devhelp/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/devel/devhelp/Makefile b/devel/devhelp/Makefile
index 1dae10a0e7ae..46839bcbda2a 100644
--- a/devel/devhelp/Makefile
+++ b/devel/devhelp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= devhelp
PORTVERSION= 0.10
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES?= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C,^([[:digit:]]+\.[[:digit:]]+).*,\1,}
@@ -16,8 +16,8 @@ DIST_SUBDIR= gnome2
MAINTAINER= ports@FreeBSD.org
COMMENT= Developer help browser for GNOME 2
-BUILD_DEPENDS= ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
-RUN_DEPENDS= ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
+BUILD_DEPENDS= ${LOCALBASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
+RUN_DEPENDS= ${LOCALBASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
MOZILLA= mozilla
@@ -30,12 +30,12 @@ MOZILLA= firefox
.endif
USE_BZIP2= yes
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gnomehack intlhack gnomeprefix libgnomeui
GNU_CONFIGURE= yes
-USE_LDCONFIG= ${X11BASE}/lib/${MOZILLA}
+USE_LDCONFIG= ${LOCALBASE}/lib/${MOZILLA}
GCONF_SCHEMAS= devhelp.schemas
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"