aboutsummaryrefslogtreecommitdiff
path: root/devel/doxygen/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/doxygen/Makefile')
-rw-r--r--devel/doxygen/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/devel/doxygen/Makefile b/devel/doxygen/Makefile
index 047c03c76f23..5f1233a47c42 100644
--- a/devel/doxygen/Makefile
+++ b/devel/doxygen/Makefile
@@ -2,7 +2,8 @@
# $FreeBSD$
PORTNAME= doxygen
-PORTVERSION= 1.8.7
+PORTVERSION= 1.8.3.1
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ftp://ftp.stack.nl/pub/users/dimitri/ \
http://ftp.stack.nl/pub/users/dimitri/
@@ -14,18 +15,15 @@ COMMENT= Documentation system for C, C++, and other languages
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= tmake:${PORTSDIR}/devel/tmake \
- flex>0:${PORTSDIR}/textproc/flex \
- python:${PORTSDIR}/lang/python
-LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
+BUILD_DEPENDS= tmake:${PORTSDIR}/devel/tmake
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
USES= bison iconv perl5 gmake
ALL_TARGET= all
HAS_CONFIGURE= yes
-MAKE_JOBS_UNSAFE= yes
QT_NONSTANDARD= yes # non-standard configure arguments
CONFIGURE_ARGS= --prefix ${PREFIX} --perl ${PERL} --make ${GMAKE} \
- --install "${INSTALL}" --flex ${LOCALBASE}/bin/flex
+ --install "${INSTALL}"
REINPLACE_ARGS= -i ''
EXTRACT_AFTER_ARGS= --exclude '*/libmd5' \