aboutsummaryrefslogtreecommitdiff
path: root/devel/epydoc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/epydoc/Makefile')
-rw-r--r--devel/epydoc/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/devel/epydoc/Makefile b/devel/epydoc/Makefile
index 24ee9bbf490a..35cefedaaf59 100644
--- a/devel/epydoc/Makefile
+++ b/devel/epydoc/Makefile
@@ -17,9 +17,23 @@ COMMENT= Python API documentation generation tool
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+USE_REINPLACE= yes
MAN1= epydoc.1 epydocgui.1
+OPTIONS= UTF8 "Use UTF-8 instead of iso-8859-1 in HTMLs" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_UTF8)
+HTMLENCODING?= utf-8
+.endif
+.if defined(HTMLENCODING)
+post-patch:
+ ${REINPLACE_CMD} 's,iso-8859-1,${HTMLENCODING},g' \
+ ${WRKSRC}/epydoc/html.py
+.endif
+
post-install:
cd ${WRKSRC}/man && ${INSTALL_MAN} ${MAN1} ${MAN1PREFIX}/man/man1
.if !defined(NOPORTDOCS)
@@ -27,4 +41,4 @@ post-install:
${CP} -R ${WRKSRC}/doc/* ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>