aboutsummaryrefslogtreecommitdiff
path: root/devel/fastcrc
diff options
context:
space:
mode:
Diffstat (limited to 'devel/fastcrc')
-rw-r--r--devel/fastcrc/Makefile21
-rw-r--r--devel/fastcrc/pkg-plist4
2 files changed, 13 insertions, 12 deletions
diff --git a/devel/fastcrc/Makefile b/devel/fastcrc/Makefile
index dee5d7b4c0dc..34f5e0ff1220 100644
--- a/devel/fastcrc/Makefile
+++ b/devel/fastcrc/Makefile
@@ -19,18 +19,19 @@ ONLY_FOR_ARCHS= i386
USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 900035
-BROKEN= Does not compile on recent FreeBSD-9
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|gcc|$${CC}| ; \
+ /strip/d' ${WRKSRC}/Makefile
do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/fc ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/fastcrc.h ${PREFIX}/include
${INSTALL_DATA} ${WRKSRC}/libfcrc.so.1 ${PREFIX}/lib
${LN} -fs ${PREFIX}/lib/libfcrc.so.1 ${PREFIX}/lib/libfcrc.so
- ${INSTALL_DATA} ${WRKSRC}/fastcrc.h ${PREFIX}/include
- ${MKDIR} ${PREFIX}/share/doc/fastcrc
- ${INSTALL_MAN} ${WRKSRC}/index.html ${PREFIX}/share/doc/fastcrc
- ${INSTALL_PROGRAM} ${WRKSRC}/fc ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/index.html ${DOCSDIR}
+.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/fastcrc/pkg-plist b/devel/fastcrc/pkg-plist
index 8efefcfe70c5..c150e9249dd0 100644
--- a/devel/fastcrc/pkg-plist
+++ b/devel/fastcrc/pkg-plist
@@ -2,5 +2,5 @@ bin/fc
include/fastcrc.h
lib/libfcrc.so
lib/libfcrc.so.1
-share/doc/fastcrc/index.html
-@dirrm share/doc/fastcrc
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%