aboutsummaryrefslogtreecommitdiff
path: root/devel/geany/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/geany/Makefile')
-rw-r--r--devel/geany/Makefile25
1 files changed, 22 insertions, 3 deletions
diff --git a/devel/geany/Makefile b/devel/geany/Makefile
index 9e165e72e279..5a52cdea0dd9 100644
--- a/devel/geany/Makefile
+++ b/devel/geany/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= geany
-PORTVERSION= 0.4
+PORTVERSION= 0.7.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,9 +17,28 @@ COMMENT= A fast and lightweight GTK+ IDE
USE_X_PREFIX= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GNOME= vte
+USE_GNOME= gtk20
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+OPTIONS= VTE "With vte" On
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.if defined(WITHOUT_VTE)
+CONFIGURE_ARGS+=--disable-vte
+.else
+USE_GNOME+= vte
+CONFIGURE_ARGS+=--enable-vte
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|gcc|${CC} ${CFLAGS}|' ${WRKSRC}/scintilla/Makefile.in
.if defined(NOPORTDOCS)
@@ -29,4 +48,4 @@ post-patch:
post-install:
${INSTALL_DATA} ${WRKSRC}/geany.desktop ${PREFIX}/share/applications
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>