aboutsummaryrefslogtreecommitdiff
path: root/devel/gnome-vfs1/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gnome-vfs1/Makefile')
-rw-r--r--devel/gnome-vfs1/Makefile54
1 files changed, 0 insertions, 54 deletions
diff --git a/devel/gnome-vfs1/Makefile b/devel/gnome-vfs1/Makefile
deleted file mode 100644
index bbf7194e26d2..000000000000
--- a/devel/gnome-vfs1/Makefile
+++ /dev/null
@@ -1,54 +0,0 @@
-# New ports collection makefile for: gnomevfs
-# Date created: 28th June 2000
-# Whom: Ade Lovett <ade@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= gnomevfs
-PORTVERSION= 1.0.5
-PORTREVISION= 6
-CATEGORIES= devel gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-vfs/1.0
-DISTNAME= gnome-vfs-${PORTVERSION}
-DIST_SUBDIR= gnome
-
-MAINTAINER= gnome@FreeBSD.org
-COMMENT= GNOME Virtual File System
-
-.if !exists(/usr/bin/bzip2)
-LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
-.endif
-
-USE_ICONV= yes
-USE_BZIP2= yes
-USE_GMAKE= yes
-USE_X_PREFIX= yes
-USE_GNOME= gnomehack gnomeprefix glib12 libxml gtk12 orbit gconf \
- gnomemimedata gnomelibs
-USE_REINPLACE= yes
-GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib" \
- BSD_PTHREAD_LIBS=${PTHREAD_LIBS}
-
-.if exists(${LOCALBASE}/lib/libcdda_paranoia.a)
-WITH_CDPARANOIA= yes
-.endif
-
-.if defined(WITH_CDPARANOIA)
-LIB_DEPENDS+= cdda_paranoia.0:${PORTSDIR}/audio/cdparanoia
-PLIST_SUB+= CDPARANOIA=""
-.else
-PLIST_SUB+= CDPARANOIA="@comment "
-.endif
-
-post-patch:
- @${FIND} ${WRKSRC} -name 'xml-i18n-*' | ${XARGS} ${REINPLACE_CMD} -e \
- 's|/usr/local/bin/perl|${PERL}|g'
- @${REINPLACE_CMD} -e 's|\%\%LOCALBASE\%\%|${LOCALBASE}|g' \
- ${WRKSRC}/libgnomevfs/libcharset/Makefile.in
-
-.include <bsd.port.mk>