aboutsummaryrefslogtreecommitdiff
path: root/devel/horde-chora/files/pkg-deinstall.in
diff options
context:
space:
mode:
Diffstat (limited to 'devel/horde-chora/files/pkg-deinstall.in')
-rw-r--r--devel/horde-chora/files/pkg-deinstall.in27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/horde-chora/files/pkg-deinstall.in b/devel/horde-chora/files/pkg-deinstall.in
new file mode 100644
index 000000000000..0ef032fe5654
--- /dev/null
+++ b/devel/horde-chora/files/pkg-deinstall.in
@@ -0,0 +1,27 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Backup Chora config files, if needed.
+
+if [ x$2 != xDEINSTALL ]; then
+ exit
+fi
+
+if [ -z "${PACKAGE_BUILDING}" ]; then
+ for cf in `ls %%CHORADIR%%/config/*php %%CHORADIR%%/config/*txt`; do
+ diff -bBqw $cf $cf.dist >/dev/null 2>&1
+ case $? in
+ 0) # original config file, will be deleted by pkg-plist
+ ;;
+ 1) # config file has been updated, must be backuped
+ cp -p $cf $cf.previous
+ echo "===> Backing-up..."
+ echo "---> $cf has been saved ***"
+ echo "---> as $cf.previous ***"
+ ;;
+ *) # not found?
+ ;;
+ esac
+ done
+fi