aboutsummaryrefslogtreecommitdiff
path: root/devel/idutils
diff options
context:
space:
mode:
Diffstat (limited to 'devel/idutils')
-rw-r--r--devel/idutils/Makefile44
-rw-r--r--devel/idutils/distinfo2
-rw-r--r--devel/idutils/files/patch-Makefile.in11
-rw-r--r--devel/idutils/files/patch-lib::Makefile.in45
-rw-r--r--devel/idutils/pkg-descr18
-rw-r--r--devel/idutils/pkg-plist13
6 files changed, 0 insertions, 133 deletions
diff --git a/devel/idutils/Makefile b/devel/idutils/Makefile
deleted file mode 100644
index 9031665a833e..000000000000
--- a/devel/idutils/Makefile
+++ /dev/null
@@ -1,44 +0,0 @@
-# New ports collection makefile for: id-utils
-# Date created: 22 Aug 1996
-# Whom: pst@freebsd.org
-#
-# $FreeBSD$
-#
-
-PORTNAME= id-utils
-PORTVERSION= 3.2d
-PORTREVISION= 4
-CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_GNU_ALPHA}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= The classic Berkeley gid/lid tools for looking up variables in code
-
-CONFLICTS= coreutils-* sh-utils-*
-
-USE_GETOPT_LONG= yes
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-
-INFO= id-utils
-
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
-
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
-.endif
-
-post-extract:
- @${RM} -f ${WRKSRC}/lib/getopt.h
-
-post-install:
- ${INSTALL_DATA} ${WRKSRC}/lisp/id-utils.el ${PREFIX}/share/emacs/site-lisp
-
-.include <bsd.port.mk>
diff --git a/devel/idutils/distinfo b/devel/idutils/distinfo
deleted file mode 100644
index eebbeda4620f..000000000000
--- a/devel/idutils/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (id-utils-3.2d.tar.gz) = 1152902c1fff4fadb8a7827ad91a80b0
-SIZE (id-utils-3.2d.tar.gz) = 357007
diff --git a/devel/idutils/files/patch-Makefile.in b/devel/idutils/files/patch-Makefile.in
deleted file mode 100644
index b6864536e1bd..000000000000
--- a/devel/idutils/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Tue Apr 6 17:28:35 1999
-+++ Makefile.in Tue Mar 30 20:10:48 2004
-@@ -95,7 +95,7 @@
-
- AUTOMAKE_OPTIONS = gnits 1.2h
-
--SUBDIRS = lib libidu intl src lisp m4 po doc testsuite
-+SUBDIRS = lib libidu intl src m4 po doc testsuite
-
- # Remove this file here (it is created via configure), not from within intl.
- DISTCLEANFILES = intl/libintl.h
diff --git a/devel/idutils/files/patch-lib::Makefile.in b/devel/idutils/files/patch-lib::Makefile.in
deleted file mode 100644
index ef4d89db44fd..000000000000
--- a/devel/idutils/files/patch-lib::Makefile.in
+++ /dev/null
@@ -1,45 +0,0 @@
---- lib/Makefile.in.orig Tue Apr 6 17:28:36 1999
-+++ lib/Makefile.in Tue Mar 30 20:20:55 2004
-@@ -100,9 +100,9 @@
- EXTRA_DIST = alloca.c basename.c dirname.c error.c fnmatch.c memcpy.c memset.c obstack.c regex.c strcasecmp.c strcspn.c strdup.c strndup.c strpbrk.c strspn.c strstr.c strtok.c
-
-
--libsys_a_SOURCES = xgetcwd.c xmalloc.c getopt.c getopt1.c
-+libsys_a_SOURCES = xgetcwd.c xmalloc.c
-
--noinst_HEADERS = ansidecl.h error.h fnmatch.h getopt.h obstack.h pathmax.h regex.h xalloca.h xdirent.h xfnmatch.h xmalloc.h xobstack.h xstddef.h xstdlib.h xstring.h xsysstat.h xunistd.h
-+noinst_HEADERS = ansidecl.h error.h fnmatch.h obstack.h pathmax.h regex.h xalloca.h xdirent.h xfnmatch.h xmalloc.h xobstack.h xstddef.h xstdlib.h xstring.h xsysstat.h xunistd.h
-
-
- INCLUDES = -I. -I$(srcdir) -I../intl -I$(top_srcdir)/intl -I.. -I$(top_srcdir)
-@@ -118,7 +118,7 @@
- LIBS = @LIBS@
- ANSI2KNR = ../src/ansi2knr
- libsys_a_DEPENDENCIES = @LIBOBJS@ @ALLOCA@
--libsys_a_OBJECTS = xgetcwd$U.o xmalloc$U.o getopt$U.o getopt1$U.o
-+libsys_a_OBJECTS = xgetcwd$U.o xmalloc$U.o
- AR = ar
- COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
- CCLD = $(CC)
-@@ -205,10 +205,6 @@
- $(CPP) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) `if test -f $(srcdir)/error.c; then echo $(srcdir)/error.c; else echo error.c; fi` | sed 's/^# \([0-9]\)/#line \1/' | $(ANSI2KNR) > error_.c
- fnmatch_.c: fnmatch.c $(ANSI2KNR)
- $(CPP) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) `if test -f $(srcdir)/fnmatch.c; then echo $(srcdir)/fnmatch.c; else echo fnmatch.c; fi` | sed 's/^# \([0-9]\)/#line \1/' | $(ANSI2KNR) > fnmatch_.c
--getopt_.c: getopt.c $(ANSI2KNR)
-- $(CPP) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) `if test -f $(srcdir)/getopt.c; then echo $(srcdir)/getopt.c; else echo getopt.c; fi` | sed 's/^# \([0-9]\)/#line \1/' | $(ANSI2KNR) > getopt_.c
--getopt1_.c: getopt1.c $(ANSI2KNR)
-- $(CPP) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) `if test -f $(srcdir)/getopt1.c; then echo $(srcdir)/getopt1.c; else echo getopt1.c; fi` | sed 's/^# \([0-9]\)/#line \1/' | $(ANSI2KNR) > getopt1_.c
- memcpy_.c: memcpy.c $(ANSI2KNR)
- $(CPP) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) `if test -f $(srcdir)/memcpy.c; then echo $(srcdir)/memcpy.c; else echo memcpy.c; fi` | sed 's/^# \([0-9]\)/#line \1/' | $(ANSI2KNR) > memcpy_.c
- memset_.c: memset.c $(ANSI2KNR)
-@@ -235,8 +231,8 @@
- $(CPP) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) `if test -f $(srcdir)/xgetcwd.c; then echo $(srcdir)/xgetcwd.c; else echo xgetcwd.c; fi` | sed 's/^# \([0-9]\)/#line \1/' | $(ANSI2KNR) > xgetcwd_.c
- xmalloc_.c: xmalloc.c $(ANSI2KNR)
- $(CPP) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) `if test -f $(srcdir)/xmalloc.c; then echo $(srcdir)/xmalloc.c; else echo xmalloc.c; fi` | sed 's/^# \([0-9]\)/#line \1/' | $(ANSI2KNR) > xmalloc_.c
--alloca_.o basename_.o dirname_.o error_.o fnmatch_.o getopt_.o \
--getopt1_.o memcpy_.o memset_.o obstack_.o regex_.o strcspn_.o strdup_.o \
-+alloca_.o basename_.o dirname_.o error_.o fnmatch_.o \
-+memcpy_.o memset_.o obstack_.o regex_.o strcspn_.o strdup_.o \
- strndup_.o strpbrk_.o strspn_.o strstr_.o strtok_.o xgetcwd_.o \
- xmalloc_.o : $(ANSI2KNR)
-
diff --git a/devel/idutils/pkg-descr b/devel/idutils/pkg-descr
deleted file mode 100644
index c62caea6dfd7..000000000000
--- a/devel/idutils/pkg-descr
+++ /dev/null
@@ -1,18 +0,0 @@
-`mkid' is a simple, fast, high-capacity, language-independent
-identifier database tool. Actually, the term `identifier' is too
-limiting--`mkid' stores tokens, be they program identifiers of any
-form, literal numbers, or words of human-readable text. Database
-queries can be issued from the command-line, or from within emacs,
-serving as an augmented tags facility.
-
-`mkid' was originally written by Greg McGary <gkm@gnu.ai.mit.edu>
-and posted to comp.sources.unix in September 1987. It was then
-maintained and enhanced by a loose knit group of programmers on the
-Internet led by Tom Horsley <Tom.Horsley@mail.hcsc.com>. Tom released
-`mkid2' on comp.sources.unix in March, 1991. Since then, Greg McGary
-has resumed maintenance and is releasing an improved version 3 under GPL.
-
-Version 3 is an interim release. Version 4 will follow in the coming
-months and include a cscope clone plus other improvements. This
-version is an improved version of version 3 (which hasn't been updated
-since 1996!), it now understands C++.
diff --git a/devel/idutils/pkg-plist b/devel/idutils/pkg-plist
deleted file mode 100644
index 6ae166ac0603..000000000000
--- a/devel/idutils/pkg-plist
+++ /dev/null
@@ -1,13 +0,0 @@
-bin/aid
-bin/defid
-bin/eid
-bin/fid
-bin/fnid
-bin/gid
-bin/lid
-bin/mkid
-bin/xtokid
-share/emacs/site-lisp/id-utils.el
-share/id-lang.map
-%%NLS%%share/locale/de/LC_MESSAGES/id-utils.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/id-utils.mo