aboutsummaryrefslogtreecommitdiff
path: root/devel/libcwd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libcwd/Makefile')
-rw-r--r--devel/libcwd/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/devel/libcwd/Makefile b/devel/libcwd/Makefile
index 4f1a8b8b03eb..1d6eb25efe52 100644
--- a/devel/libcwd/Makefile
+++ b/devel/libcwd/Makefile
@@ -22,8 +22,15 @@ CONFIGURE_ARGS= --disable-threading
USE_GMAKE= yes
INSTALLS_SHLIB= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 501103
+# Work around bsd.port.mk bug: Does not currently set up MAKE_ENV for gcc 3.2 and 3.3
+MAKE_ENV+= CC="${CC}" CXX="${CXX}"
+.endif
+
# dirty hack
post-configure:
@${CP} -f ${WRKSRC}/include/sys.ho ${WRKSRC}/include/sys.h
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>