aboutsummaryrefslogtreecommitdiff
path: root/devel/libevent
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libevent')
-rw-r--r--devel/libevent/Makefile33
-rw-r--r--devel/libevent/distinfo2
-rw-r--r--devel/libevent/files/patch-evdns.c52
-rw-r--r--devel/libevent/files/patch-event.c26
-rw-r--r--devel/libevent/files/patch-evutil.c11
-rw-r--r--devel/libevent/files/patch-http.c20
-rw-r--r--devel/libevent/files/patch-signal.c38
-rw-r--r--devel/libevent/pkg-descr17
-rw-r--r--devel/libevent/pkg-plist24
9 files changed, 0 insertions, 223 deletions
diff --git a/devel/libevent/Makefile b/devel/libevent/Makefile
deleted file mode 100644
index a83ebf46246c..000000000000
--- a/devel/libevent/Makefile
+++ /dev/null
@@ -1,33 +0,0 @@
-# Created by: Pete Fritchman <petef@databits.net>
-# $FreeBSD$
-
-PORTNAME= libevent
-PORTVERSION= 1.4.14b
-PORTREVISION?= 3
-CATEGORIES= devel
-MASTER_SITES= http://monkey.org/~provos/
-DISTNAME= ${PORTNAME}-${DISTVERSION}-stable
-
-MAINTAINER= mm@FreeBSD.org
-COMMENT?= Provides an API to execute callback functions on certain events
-
-LICENSE= BSD3CLAUSE
-
-GNU_CONFIGURE= yes
-.if !defined(_BUILDING_LIBEVENT_HIPHOP)
-USE_LDCONFIG= yes
-.endif
-
-pre-configure:
- @${MKDIR} ${WRKSRC}/m4
-
-post-patch:
- @${REINPLACE_CMD} -e 's,CFLAGS =,CFLAGS +=,' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e '/LIBS/s/-lrt//g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|<stdint.h>|<inttypes.h>|' \
- ${WRKSRC}/epoll.c ${WRKSRC}/epoll_sub.c ${WRKSRC}/evdns.c
-
-regression-test: build
- @(${SH} ${WRKSRC}/test/regress)
-
-.include <bsd.port.mk>
diff --git a/devel/libevent/distinfo b/devel/libevent/distinfo
deleted file mode 100644
index 41a84f2139f3..000000000000
--- a/devel/libevent/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (libevent-1.4.14b-stable.tar.gz) = afa61b476a222ba43fc7cca2d24849ab0bbd940124400cb699915d3c60e46301
-SIZE (libevent-1.4.14b-stable.tar.gz) = 474874
diff --git a/devel/libevent/files/patch-evdns.c b/devel/libevent/files/patch-evdns.c
deleted file mode 100644
index 7ac2668f3773..000000000000
--- a/devel/libevent/files/patch-evdns.c
+++ /dev/null
@@ -1,52 +0,0 @@
---- evdns.c.orig 2011-02-22 09:47:55.243428037 +0100
-+++ evdns.c 2011-02-22 09:48:00.454027469 +0100
-@@ -158,6 +158,15 @@
-
- #define CLASS_INET EVDNS_CLASS_INET
-
-+#ifdef HAVE_SETFD
-+#define FD_CLOSEONEXEC(x) do { \
-+ if (fcntl(x, F_SETFD, 1) == -1) \
-+ event_warn("fcntl(%d, F_SETFD)", x); \
-+ } while (0)
-+#else
-+#define FD_CLOSEONEXEC(x) (void)0
-+#endif
-+
- struct request {
- u8 *request; /* the dns packet data */
- unsigned int request_len;
-@@ -1099,20 +1108,12 @@
- static u16
- transaction_id_pick(void) {
- for (;;) {
-- const struct request *req = req_head, *started_at;
- u16 trans_id = trans_id_function();
-
- if (trans_id == 0xffff) continue;
-- /* now check to see if that id is already inflight */
-- req = started_at = req_head;
-- if (req) {
-- do {
-- if (req->trans_id == trans_id) break;
-- req = req->next;
-- } while (req != started_at);
-- }
-- /* we didn't find it, so this is a good id */
-- if (req == started_at) return trans_id;
-+
-+ if (request_find_from_trans_id(trans_id) == NULL)
-+ return trans_id;
- }
- }
-
-@@ -2132,7 +2133,8 @@
-
- ns->socket = socket(PF_INET, SOCK_DGRAM, 0);
- if (ns->socket < 0) { err = 1; goto out1; }
-- evutil_make_socket_nonblocking(ns->socket);
-+ FD_CLOSEONEXEC(ns->socket);
-+ evutil_make_socket_nonblocking(ns->socket);
-
- ns->address = address;
- ns->port = htons(port);
diff --git a/devel/libevent/files/patch-event.c b/devel/libevent/files/patch-event.c
deleted file mode 100644
index fda2586804ca..000000000000
--- a/devel/libevent/files/patch-event.c
+++ /dev/null
@@ -1,26 +0,0 @@
---- event.c.orig 2011-02-22 09:41:20.016483538 +0100
-+++ event.c 2011-02-22 09:41:56.252380281 +0100
-@@ -279,9 +279,14 @@
- int res = 0;
- struct event *ev;
-
-+#if 0
-+ /* Right now, reinit always takes effect, since even if the
-+ backend doesn't require it, the signal socketpair code does.
-+ */
- /* check if this event mechanism requires reinit */
- if (!evsel->need_reinit)
- return (0);
-+#endif
-
- /* prevent internal delete */
- if (base->sig.ev_signal_added) {
-@@ -294,7 +299,7 @@
- EVLIST_ACTIVE);
- base->sig.ev_signal_added = 0;
- }
--
-+
- if (base->evsel->dealloc != NULL)
- base->evsel->dealloc(base, base->evbase);
- evbase = base->evbase = evsel->init(base);
diff --git a/devel/libevent/files/patch-evutil.c b/devel/libevent/files/patch-evutil.c
deleted file mode 100644
index 292d3987a616..000000000000
--- a/devel/libevent/files/patch-evutil.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- evutil.c.orig 2011-02-22 09:39:26.529403997 +0100
-+++ evutil.c 2011-02-22 09:41:40.352952848 +0100
-@@ -169,7 +169,7 @@
- }
- #else
- {
-- long flags;
-+ int flags;
- if ((flags = fcntl(fd, F_GETFL, NULL)) < 0) {
- event_warn("fcntl(%d, F_GETFL)", fd);
- return -1;
diff --git a/devel/libevent/files/patch-http.c b/devel/libevent/files/patch-http.c
deleted file mode 100644
index 825910da8ea7..000000000000
--- a/devel/libevent/files/patch-http.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- http.c.orig 2011-02-22 09:41:25.224559892 +0100
-+++ http.c 2011-02-22 09:42:00.208495705 +0100
-@@ -390,7 +398,7 @@
- /* Add the content length on a post request if missing */
- if (req->type == EVHTTP_REQ_POST &&
- evhttp_find_header(req->output_headers, "Content-Length") == NULL){
-- char size[12];
-+ char size[22];
- evutil_snprintf(size, sizeof(size), "%ld",
- (long)EVBUFFER_LENGTH(req->output_buffer));
- evhttp_add_header(req->output_headers, "Content-Length", size);
-@@ -447,7 +455,7 @@
- {
- if (evhttp_find_header(headers, "Transfer-Encoding") == NULL &&
- evhttp_find_header(headers, "Content-Length") == NULL) {
-- char len[12];
-+ char len[22];
- evutil_snprintf(len, sizeof(len), "%ld", content_length);
- evhttp_add_header(headers, "Content-Length", len);
- }
diff --git a/devel/libevent/files/patch-signal.c b/devel/libevent/files/patch-signal.c
deleted file mode 100644
index 4b7301a3e5dc..000000000000
--- a/devel/libevent/files/patch-signal.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- signal.c.orig 2011-02-22 09:41:14.711661986 +0100
-+++ signal.c 2011-02-22 09:41:52.113522401 +0100
-@@ -67,6 +67,13 @@
-
- static void evsignal_handler(int sig);
-
-+#ifdef WIN32
-+#define error_is_eagain(err) \
-+ ((err) == EAGAIN || (err) == WSAEWOULDBLOCK)
-+#else
-+#define error_is_eagain(err) ((err) == EAGAIN)
-+#endif
-+
- /* Callback for when the signal handler write a byte to our signaling socket */
- static void
- evsignal_cb(int fd, short what, void *arg)
-@@ -79,8 +86,11 @@
- #endif
-
- n = recv(fd, signals, sizeof(signals), 0);
-- if (n == -1)
-- event_err(1, "%s: read", __func__);
-+ if (n == -1) {
-+ int err = EVUTIL_SOCKET_ERROR();
-+ if (! error_is_eagain(err))
-+ event_err(1, "%s: read", __func__);
-+ }
- }
-
- #ifdef HAVE_SETFD
-@@ -125,6 +135,7 @@
- TAILQ_INIT(&base->sig.evsigevents[i]);
-
- evutil_make_socket_nonblocking(base->sig.ev_signal_pair[0]);
-+ evutil_make_socket_nonblocking(base->sig.ev_signal_pair[1]);
-
- event_set(&base->sig.ev_signal, base->sig.ev_signal_pair[1],
- EV_READ | EV_PERSIST, evsignal_cb, &base->sig.ev_signal);
diff --git a/devel/libevent/pkg-descr b/devel/libevent/pkg-descr
deleted file mode 100644
index e15839b4b2a8..000000000000
--- a/devel/libevent/pkg-descr
+++ /dev/null
@@ -1,17 +0,0 @@
-The libevent API provides a mechanism to execute a callback function when
-a specific event occurs on a file descriptor or after a timeout has been
-reached.
-
-libevent is meant to replace the asynchronous event loop found in event
-driven network servers. An application just needs to call event_dispatch()
-and can then add or remove events dynamically without having to change the
-event loop.
-
-Currently, libevent supports kqueue(2), select(2), poll(2), and epoll(4).
-The internal event mechanism is completely independent of the exposed event
-API, and a simple update of libevent can provide new functionality without
-having to redesign the applications. As a result, Libevent allows for
-portable application development and provides the most scalable event
-notification mechanism available on an operating system.
-
-WWW: http://libevent.org/
diff --git a/devel/libevent/pkg-plist b/devel/libevent/pkg-plist
deleted file mode 100644
index 2185c0e0313f..000000000000
--- a/devel/libevent/pkg-plist
+++ /dev/null
@@ -1,24 +0,0 @@
-bin/event_rpcgen.py
-include/event-config.h
-include/event.h
-include/evhttp.h
-include/evdns.h
-include/evrpc.h
-include/evutil.h
-lib/libevent-1.4.so
-lib/libevent-1.4.so.4
-lib/libevent_core-1.4.so
-lib/libevent_core-1.4.so.4
-lib/libevent_core.a
-lib/libevent_core.la
-lib/libevent_core.so
-lib/libevent_extra-1.4.so
-lib/libevent_extra-1.4.so.4
-lib/libevent_extra.a
-lib/libevent_extra.la
-lib/libevent_extra.so
-lib/libevent.a
-lib/libevent.la
-lib/libevent.so
-man/man3/event.3.gz
-man/man3/evdns.3.gz