aboutsummaryrefslogtreecommitdiff
path: root/devel/libglademm24/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libglademm24/Makefile')
-rw-r--r--devel/libglademm24/Makefile25
1 files changed, 18 insertions, 7 deletions
diff --git a/devel/libglademm24/Makefile b/devel/libglademm24/Makefile
index 4c9e7a70fc01..18e09eb0a16f 100644
--- a/devel/libglademm24/Makefile
+++ b/devel/libglademm24/Makefile
@@ -6,24 +6,35 @@
#
PORTNAME= libglademm
-PORTVERSION= 2.1.2
-PORTREVISION= 2
+PORTVERSION= 2.4.0
CATEGORIES= devel gnome
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= gtkmm
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= gnome2
MAINTAINER= bland@FreeBSD.org
COMMENT= C++ wrapper for libglade2 library
-LIB_DEPENDS= gtkmm-2.0:${PORTSDIR}/x11-toolkits/gtk--2
+LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
+USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack libglade2
-USE_LIBTOOL_VER= 13
+USE_GCC= 3.3
+USE_REINPLACE= yes
+USE_GNOME= gnomehack lthack libglade2
+USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-static
+PLIST_SUB= VERSION="2.4" API_VERSION="2.4"
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^SUBDIRS =/s/examples//' \
+ ${WRKSRC}/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's|^\(SUBDIRS = .*\)\(docs\)\(.*\)|\1\3|' ${WRKSRC}/Makefile.in
+.endif
+
.include <bsd.port.mk>