aboutsummaryrefslogtreecommitdiff
path: root/devel/libhtp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libhtp/Makefile')
-rw-r--r--devel/libhtp/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/devel/libhtp/Makefile b/devel/libhtp/Makefile
index dff6c82ebf33..bf619530164f 100644
--- a/devel/libhtp/Makefile
+++ b/devel/libhtp/Makefile
@@ -18,12 +18,17 @@ ACLOCAL_ARGS= -Im4
USE_LDCONFIG= yes
USES= pkgconfig pathfix iconv
-CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE}
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib \
- -liconv
+ ${ICONV_LIB}
+
+.include <bsd.port.pre.mk>
+
+.if empty(ICONV_LIB)
+CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE}
+.endif
pre-configure:
@${REINPLACE_CMD} -Ee 's,^(pkgconfigdir = ).*,\1$$(exec_prefix)/libdata/pkgconfig,' ${WRKSRC}/Makefile.am
@cd ${WRKSRC} && ${SH} ./autogen.sh
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>