aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm29
diff options
context:
space:
mode:
Diffstat (limited to 'devel/llvm29')
-rw-r--r--devel/llvm29/Makefile51
-rw-r--r--devel/llvm29/distinfo3
-rw-r--r--devel/llvm29/files/patch-lib_ExecutionEngine_Interpreter_Execution.cpp61
-rw-r--r--devel/llvm29/files/patch-lib_Transforms_Scalar_LoopIndexSplit.cpp21
-rw-r--r--devel/llvm29/pkg-descr10
-rw-r--r--devel/llvm29/pkg-plist418
6 files changed, 0 insertions, 564 deletions
diff --git a/devel/llvm29/Makefile b/devel/llvm29/Makefile
deleted file mode 100644
index e3b825effd6a..000000000000
--- a/devel/llvm29/Makefile
+++ /dev/null
@@ -1,51 +0,0 @@
-# New ports collection makefile for: llvm
-# Date created: 20 Nov 2005
-# Whom: Hye-Shik Chang
-#
-# $FreeBSD$
-#
-
-PORTNAME= llvm
-PORTVERSION= 2.1
-CATEGORIES= devel lang
-MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
-
-MAINTAINER= brooks@FreeBSD.org
-COMMENT= Low Level Virtual Machine
-
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_PERL5_BUILD=yes
-USE_GCC= 3.3+
-
-CONFIGURE_FLAGS+= --enable-optimized
-
-MAN1= bugpoint.1 llc.1 lli.1 llvm-ar.1 \
- llvm-as.1 llvm-bcanalyzer.1 llvm-config.1 llvm-db.1 \
- llvm-dis.1 llvm-extract.1 llvm-ld.1 llvm-link.1 llvm-nm.1 \
- llvm-prof.1 llvm-ranlib.1 llvm-upgrade.1 \
- llvm2cpp.1 llvmc.1 llvmgcc.1 \
- llvmgxx.1 opt.1 stkrc.1 tblgen.1
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "sparc64" && ${OSVERSION} >= 700042
-BROKEN= does not build on sparc64
-.endif
-
-.if ${PERL_LEVEL} < 500800
-BROKEN= does not compile with perl ${PERL_VERSION}
-.endif
-
-post-patch:
- ${REINPLACE_CMD} -e 's,\(PROJ_docsdir.*:=\).*$$,\1${DOCSDIR},g' \
- ${WRKSRC}/Makefile.config.in
- ${REINPLACE_CMD} -e 's,\(PROJ_mandir.*:=\).*$$,\1${MANPREFIX}/man,g' \
- ${WRKSRC}/Makefile.config.in
-
-post-install:
- @${RM} ${PREFIX}/bin/.dir \
- ${PREFIX}/etc/llvm/.dir \
- ${PREFIX}/lib/.dir
-
-.include <bsd.port.post.mk>
diff --git a/devel/llvm29/distinfo b/devel/llvm29/distinfo
deleted file mode 100644
index 17809141f9f0..000000000000
--- a/devel/llvm29/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (llvm-2.1.tar.gz) = b930e7213b37acc934d0d163cf13af18
-SHA256 (llvm-2.1.tar.gz) = 8cabd422f249ada736d864fc8a1f4d14aabefacb6f860c9beefbc53f93e0f96c
-SIZE (llvm-2.1.tar.gz) = 5062241
diff --git a/devel/llvm29/files/patch-lib_ExecutionEngine_Interpreter_Execution.cpp b/devel/llvm29/files/patch-lib_ExecutionEngine_Interpreter_Execution.cpp
deleted file mode 100644
index 5246aae1207d..000000000000
--- a/devel/llvm29/files/patch-lib_ExecutionEngine_Interpreter_Execution.cpp
+++ /dev/null
@@ -1,61 +0,0 @@
-Author: lattner
-Date: Fri Sep 21 13:30:39 2007
-New Revision: 42205
-
-Log:
-#ifdef out unsafe tracing code, which fixes PR1689
-
-==============================================================================
---- lib/ExecutionEngine/Interpreter/Execution.cpp (original)
-+++ lib/ExecutionEngine/Interpreter/Execution.cpp Fri Sep 21 13:30:39 2007
-@@ -1338,20 +1338,6 @@
- StackFrame.VarArgs.assign(ArgVals.begin()+i, ArgVals.end());
- }
-
--static void PrintGenericValue(const GenericValue &Val, const Type* Ty) {
-- switch (Ty->getTypeID()) {
-- default: assert(0 && "Invalid GenericValue Type");
-- case Type::VoidTyID: DOUT << "void"; break;
-- case Type::FloatTyID: DOUT << "float " << Val.FloatVal; break;
-- case Type::DoubleTyID: DOUT << "double " << Val.DoubleVal; break;
-- case Type::PointerTyID: DOUT << "void* " << intptr_t(Val.PointerVal); break;
-- case Type::IntegerTyID:
-- DOUT << "i" << Val.IntVal.getBitWidth() << " "
-- << Val.IntVal.toStringUnsigned(10)
-- << " (0x" << Val.IntVal.toStringUnsigned(16) << ")\n";
-- break;
-- }
--}
-
- void Interpreter::run() {
- while (!ECStack.empty()) {
-@@ -1364,12 +1350,28 @@
-
- DOUT << "About to interpret: " << I;
- visit(I); // Dispatch to one of the visit* methods...
-+#if 0
-+ // This is not safe, as visiting the instruction could lower it and free I.
- #ifndef NDEBUG
- if (!isa<CallInst>(I) && !isa<InvokeInst>(I) &&
- I.getType() != Type::VoidTy) {
- DOUT << " --> ";
-- PrintGenericValue(SF.Values[&I], I.getType());
-+ const GenericValue &Val = SF.Values[&I];
-+ switch (I.getType()->getTypeID()) {
-+ default: assert(0 && "Invalid GenericValue Type");
-+ case Type::VoidTyID: DOUT << "void"; break;
-+ case Type::FloatTyID: DOUT << "float " << Val.FloatVal; break;
-+ case Type::DoubleTyID: DOUT << "double " << Val.DoubleVal; break;
-+ case Type::PointerTyID: DOUT << "void* " << intptr_t(Val.PointerVal);
-+ break;
-+ case Type::IntegerTyID:
-+ DOUT << "i" << Val.IntVal.getBitWidth() << " "
-+ << Val.IntVal.toStringUnsigned(10)
-+ << " (0x" << Val.IntVal.toStringUnsigned(16) << ")\n";
-+ break;
-+ }
- }
- #endif
-+#endif
- }
- }
diff --git a/devel/llvm29/files/patch-lib_Transforms_Scalar_LoopIndexSplit.cpp b/devel/llvm29/files/patch-lib_Transforms_Scalar_LoopIndexSplit.cpp
deleted file mode 100644
index e3a82d5972aa..000000000000
--- a/devel/llvm29/files/patch-lib_Transforms_Scalar_LoopIndexSplit.cpp
+++ /dev/null
@@ -1,21 +0,0 @@
-Author: dpatel
-Date: Thu Sep 20 18:01:50 2007
-New Revision: 42178
-
-Log:
-Don't increment invalid iterator.
-
-==============================================================================
---- lib/Transforms/Scalar/LoopIndexSplit.cpp (original)
-+++ lib/Transforms/Scalar/LoopIndexSplit.cpp Thu Sep 20 18:01:50 2007
-@@ -928,8 +928,9 @@
- while (!WorkList.empty()) {
- BasicBlock *BB = WorkList.back(); WorkList.pop_back();
- for(BasicBlock::iterator BBI = BB->begin(), BBE = BB->end();
-- BBI != BBE; ++BBI) {
-+ BBI != BBE; ) {
- Instruction *I = BBI;
-+ ++BBI;
- I->replaceAllUsesWith(UndefValue::get(I->getType()));
- I->eraseFromParent();
- }
diff --git a/devel/llvm29/pkg-descr b/devel/llvm29/pkg-descr
deleted file mode 100644
index ba43ebf6c842..000000000000
--- a/devel/llvm29/pkg-descr
+++ /dev/null
@@ -1,10 +0,0 @@
-Low Level Virtual Machine (LLVM) is:
-- A compilation strategy designed to enable effective program
- optimization across the entire lifetime of a program.
-- A virtual instruction set.
-- A compiler infrastructure.
-- LLVM does not imply things that you would expect from a high-level
- virtual machine. It does not require garbage collection or run-time
- code generation.
-
-WWW: http://llvm.cs.uiuc.edu/
diff --git a/devel/llvm29/pkg-plist b/devel/llvm29/pkg-plist
deleted file mode 100644
index 24f8485f0b03..000000000000
--- a/devel/llvm29/pkg-plist
+++ /dev/null
@@ -1,418 +0,0 @@
-bin/bugpoint
-bin/gccas
-bin/gccld
-bin/llc
-bin/lli
-bin/llvm-ar
-bin/llvm-as
-bin/llvm-bcanalyzer
-bin/llvm-config
-bin/llvm-db
-bin/llvm-dis
-bin/llvm-extract
-bin/llvm-ld
-bin/llvm-link
-bin/llvm-nm
-bin/llvm-prof
-bin/llvm-ranlib
-bin/llvm-stub
-bin/llvm-upgrade
-bin/llvm2cpp
-bin/llvmc
-bin/opt
-etc/llvm/c
-etc/llvm/c++
-etc/llvm/cpp
-etc/llvm/cxx
-etc/llvm/ll
-etc/llvm/st
-include/llvm-c/LinkTimeOptimizer.h
-include/llvm/ADT/APFloat.h
-include/llvm/ADT/APInt.h
-include/llvm/ADT/APSInt.h
-include/llvm/ADT/BitVector.h
-include/llvm/ADT/DenseMap.h
-include/llvm/ADT/DepthFirstIterator.h
-include/llvm/ADT/EquivalenceClasses.h
-include/llvm/ADT/FoldingSet.h
-include/llvm/ADT/GraphTraits.h
-include/llvm/ADT/HashExtras.h
-include/llvm/ADT/IndexedMap.h
-include/llvm/ADT/PostOrderIterator.h
-include/llvm/ADT/SCCIterator.h
-include/llvm/ADT/STLExtras.h
-include/llvm/ADT/SetOperations.h
-include/llvm/ADT/SetVector.h
-include/llvm/ADT/SmallPtrSet.h
-include/llvm/ADT/SmallSet.h
-include/llvm/ADT/SmallString.h
-include/llvm/ADT/SmallVector.h
-include/llvm/ADT/SparseBitVector.h
-include/llvm/ADT/Statistic.h
-include/llvm/ADT/StringExtras.h
-include/llvm/ADT/StringMap.h
-include/llvm/ADT/Tree.h
-include/llvm/ADT/UniqueVector.h
-include/llvm/ADT/VectorExtras.h
-include/llvm/ADT/hash_map
-include/llvm/ADT/hash_set
-include/llvm/ADT/ilist
-include/llvm/ADT/iterator
-include/llvm/AbstractTypeUser.h
-include/llvm/Analysis/AliasAnalysis.h
-include/llvm/Analysis/AliasSetTracker.h
-include/llvm/Analysis/CFGPrinter.h
-include/llvm/Analysis/CallGraph.h
-include/llvm/Analysis/ConstantFolding.h
-include/llvm/Analysis/ConstantsScanner.h
-include/llvm/Analysis/Dominators.h
-include/llvm/Analysis/FindUsedTypes.h
-include/llvm/Analysis/Interval.h
-include/llvm/Analysis/IntervalIterator.h
-include/llvm/Analysis/IntervalPartition.h
-include/llvm/Analysis/LoadValueNumbering.h
-include/llvm/Analysis/LoopInfo.h
-include/llvm/Analysis/LoopPass.h
-include/llvm/Analysis/MemoryDependenceAnalysis.h
-include/llvm/Analysis/Passes.h
-include/llvm/Analysis/PostDominators.h
-include/llvm/Analysis/ProfileInfo.h
-include/llvm/Analysis/ProfileInfoLoader.h
-include/llvm/Analysis/ProfileInfoTypes.h
-include/llvm/Analysis/ScalarEvolution.h
-include/llvm/Analysis/ScalarEvolutionExpander.h
-include/llvm/Analysis/ScalarEvolutionExpressions.h
-include/llvm/Analysis/Trace.h
-include/llvm/Analysis/ValueNumbering.h
-include/llvm/Analysis/Verifier.h
-include/llvm/Argument.h
-include/llvm/Assembly/AsmAnnotationWriter.h
-include/llvm/Assembly/Parser.h
-include/llvm/Assembly/PrintModulePass.h
-include/llvm/Assembly/Writer.h
-include/llvm/AutoUpgrade.h
-include/llvm/BasicBlock.h
-include/llvm/Bitcode/Archive.h
-include/llvm/Bitcode/BitCodes.h
-include/llvm/Bitcode/BitstreamReader.h
-include/llvm/Bitcode/BitstreamWriter.h
-include/llvm/Bitcode/LLVMBitCodes.h
-include/llvm/Bitcode/ReaderWriter.h
-include/llvm/CallGraphSCCPass.h
-include/llvm/CallingConv.h
-include/llvm/CodeGen/AsmPrinter.h
-include/llvm/CodeGen/CallingConvLower.h
-include/llvm/CodeGen/DwarfWriter.h
-include/llvm/CodeGen/ELFRelocation.h
-include/llvm/CodeGen/FileWriters.h
-include/llvm/CodeGen/IntrinsicLowering.h
-include/llvm/CodeGen/LinkAllCodegenComponents.h
-include/llvm/CodeGen/LiveInterval.h
-include/llvm/CodeGen/LiveIntervalAnalysis.h
-include/llvm/CodeGen/LiveVariables.h
-include/llvm/CodeGen/MachORelocation.h
-include/llvm/CodeGen/MachineBasicBlock.h
-include/llvm/CodeGen/MachineCodeEmitter.h
-include/llvm/CodeGen/MachineConstantPool.h
-include/llvm/CodeGen/MachineFrameInfo.h
-include/llvm/CodeGen/MachineFunction.h
-include/llvm/CodeGen/MachineFunctionPass.h
-include/llvm/CodeGen/MachineInstr.h
-include/llvm/CodeGen/MachineInstrBuilder.h
-include/llvm/CodeGen/MachineJumpTableInfo.h
-include/llvm/CodeGen/MachineLocation.h
-include/llvm/CodeGen/MachineModuleInfo.h
-include/llvm/CodeGen/MachinePassRegistry.h
-include/llvm/CodeGen/MachineRelocation.h
-include/llvm/CodeGen/Passes.h
-include/llvm/CodeGen/RegAllocRegistry.h
-include/llvm/CodeGen/RegisterCoalescer.h
-include/llvm/CodeGen/RegisterScavenging.h
-include/llvm/CodeGen/RuntimeLibcalls.h
-include/llvm/CodeGen/SSARegMap.h
-include/llvm/CodeGen/SchedGraphCommon.h
-include/llvm/CodeGen/ScheduleDAG.h
-include/llvm/CodeGen/SchedulerRegistry.h
-include/llvm/CodeGen/SelectionDAG.h
-include/llvm/CodeGen/SelectionDAGISel.h
-include/llvm/CodeGen/SelectionDAGNodes.h
-include/llvm/CodeGen/SimpleRegisterCoalescing.h
-include/llvm/CodeGen/ValueTypes.h
-include/llvm/CodeGen/ValueTypes.td
-include/llvm/Config/alloca.h
-include/llvm/Config/config.h
-include/llvm/Constant.h
-include/llvm/Constants.h
-include/llvm/Debugger/Debugger.h
-include/llvm/Debugger/InferiorProcess.h
-include/llvm/Debugger/ProgramInfo.h
-include/llvm/Debugger/RuntimeInfo.h
-include/llvm/Debugger/SourceFile.h
-include/llvm/Debugger/SourceLanguage.h
-include/llvm/DerivedTypes.h
-include/llvm/ExecutionEngine/ExecutionEngine.h
-include/llvm/ExecutionEngine/GenericValue.h
-include/llvm/ExecutionEngine/Interpreter.h
-include/llvm/ExecutionEngine/JIT.h
-include/llvm/Function.h
-include/llvm/GlobalAlias.h
-include/llvm/GlobalValue.h
-include/llvm/GlobalVariable.h
-include/llvm/InlineAsm.h
-include/llvm/InstrTypes.h
-include/llvm/Instruction.def
-include/llvm/Instruction.h
-include/llvm/Instructions.h
-include/llvm/IntrinsicInst.h
-include/llvm/Intrinsics.gen
-include/llvm/Intrinsics.h
-include/llvm/Intrinsics.td
-include/llvm/IntrinsicsPowerPC.td
-include/llvm/IntrinsicsX86.td
-include/llvm/LinkAllPasses.h
-include/llvm/LinkAllVMCore.h
-include/llvm/LinkTimeOptimizer.h
-include/llvm/Linker.h
-include/llvm/Module.h
-include/llvm/ModuleProvider.h
-include/llvm/ParameterAttributes.h
-include/llvm/Pass.h
-include/llvm/PassAnalysisSupport.h
-include/llvm/PassManager.h
-include/llvm/PassManagers.h
-include/llvm/PassSupport.h
-include/llvm/Support/AIXDataTypesFix.h
-include/llvm/Support/Allocator.h
-include/llvm/Support/Annotation.h
-include/llvm/Support/CFG.h
-include/llvm/Support/CallSite.h
-include/llvm/Support/Casting.h
-include/llvm/Support/CommandLine.h
-include/llvm/Support/Compiler.h
-include/llvm/Support/ConstantRange.h
-include/llvm/Support/DOTGraphTraits.h
-include/llvm/Support/DataTypes.h
-include/llvm/Support/Debug.h
-include/llvm/Support/Dwarf.h
-include/llvm/Support/DynamicLinker.h
-include/llvm/Support/ELF.h
-include/llvm/Support/FileUtilities.h
-include/llvm/Support/GetElementPtrTypeIterator.h
-include/llvm/Support/GraphWriter.h
-include/llvm/Support/InstIterator.h
-include/llvm/Support/InstVisitor.h
-include/llvm/Support/LLVMBuilder.h
-include/llvm/Support/LeakDetector.h
-include/llvm/Support/ManagedStatic.h
-include/llvm/Support/Mangler.h
-include/llvm/Support/MathExtras.h
-include/llvm/Support/MemoryBuffer.h
-include/llvm/Support/MutexGuard.h
-include/llvm/Support/OutputBuffer.h
-include/llvm/Support/PassNameParser.h
-include/llvm/Support/PatternMatch.h
-include/llvm/Support/PluginLoader.h
-include/llvm/Support/SlowOperationInformer.h
-include/llvm/Support/StableBasicBlockNumbering.h
-include/llvm/Support/Streams.h
-include/llvm/Support/SystemUtils.h
-include/llvm/Support/Timer.h
-include/llvm/Support/TypeInfo.h
-include/llvm/Support/type_traits.h
-include/llvm/SymbolTableListTraits.h
-include/llvm/System/Alarm.h
-include/llvm/System/Disassembler.h
-include/llvm/System/DynamicLibrary.h
-include/llvm/System/IncludeFile.h
-include/llvm/System/LICENSE.TXT
-include/llvm/System/MappedFile.h
-include/llvm/System/Memory.h
-include/llvm/System/Mutex.h
-include/llvm/System/Path.h
-include/llvm/System/Process.h
-include/llvm/System/Program.h
-include/llvm/System/Signals.h
-include/llvm/System/TimeValue.h
-include/llvm/Target/MRegisterInfo.h
-include/llvm/Target/SubtargetFeature.h
-include/llvm/Target/TargetAsmInfo.h
-include/llvm/Target/TargetData.h
-include/llvm/Target/TargetELFWriterInfo.h
-include/llvm/Target/TargetFrameInfo.h
-include/llvm/Target/TargetInstrInfo.h
-include/llvm/Target/TargetInstrItineraries.h
-include/llvm/Target/TargetJITInfo.h
-include/llvm/Target/TargetLowering.h
-include/llvm/Target/TargetMachOWriterInfo.h
-include/llvm/Target/TargetMachine.h
-include/llvm/Target/TargetMachineRegistry.h
-include/llvm/Target/TargetOptions.h
-include/llvm/Target/TargetSubtarget.h
-include/llvm/Transforms/IPO.h
-include/llvm/Transforms/IPO/InlinerPass.h
-include/llvm/Transforms/Instrumentation.h
-include/llvm/Transforms/RSProfiling.h
-include/llvm/Transforms/Scalar.h
-include/llvm/Transforms/Utils/BasicBlockUtils.h
-include/llvm/Transforms/Utils/BasicInliner.h
-include/llvm/Transforms/Utils/Cloning.h
-include/llvm/Transforms/Utils/FunctionUtils.h
-include/llvm/Transforms/Utils/InlineCost.h
-include/llvm/Transforms/Utils/Local.h
-include/llvm/Transforms/Utils/PromoteMemToReg.h
-include/llvm/Transforms/Utils/UnifyFunctionExitNodes.h
-include/llvm/Type.h
-include/llvm/TypeSymbolTable.h
-include/llvm/Use.h
-include/llvm/User.h
-include/llvm/Value.h
-include/llvm/ValueSymbolTable.h
-lib/LLVMARM.o
-lib/LLVMAlpha.o
-lib/LLVMCBackend.o
-lib/LLVMExecutionEngine.o
-lib/LLVMHello.a
-lib/LLVMHello.la
-lib/LLVMHello.so
-lib/LLVMHello.so.0
-lib/LLVMIA64.o
-lib/LLVMInterpreter.o
-lib/LLVMJIT.o
-lib/LLVMMSIL.o
-lib/LLVMMips.o
-lib/LLVMPowerPC.o
-lib/LLVMSparc.o
-lib/LLVMX86.o
-lib/libLLVMAnalysis.a
-lib/libLLVMArchive.a
-lib/libLLVMAsmParser.a
-lib/libLLVMBitReader.a
-lib/libLLVMBitWriter.a
-lib/libLLVMCodeGen.a
-lib/libLLVMCore.a
-lib/libLLVMDebugger.a
-lib/libLLVMInstrumentation.a
-lib/libLLVMLinker.a
-lib/libLLVMScalarOpts.a
-lib/libLLVMSelectionDAG.a
-lib/libLLVMSupport.a
-lib/libLLVMSystem.a
-lib/libLLVMTarget.a
-lib/libLLVMTransformUtils.a
-lib/libLLVMipa.a
-lib/libLLVMipo.a
-lib/libLLVMlto.a
-%%DOCSDIR%%/html.tar.gz
-%%DOCSDIR%%/html/AliasAnalysis.html
-%%DOCSDIR%%/html/BitCodeFormat.html
-%%DOCSDIR%%/html/Bugpoint.html
-%%DOCSDIR%%/html/CFEBuildInstrs.html
-%%DOCSDIR%%/html/CodeGenerator.html
-%%DOCSDIR%%/html/CodingStandards.html
-%%DOCSDIR%%/html/CommandGuide/bugpoint.html
-%%DOCSDIR%%/html/CommandGuide/index.html
-%%DOCSDIR%%/html/CommandGuide/llc.html
-%%DOCSDIR%%/html/CommandGuide/lli.html
-%%DOCSDIR%%/html/CommandGuide/llvm-ar.html
-%%DOCSDIR%%/html/CommandGuide/llvm-as.html
-%%DOCSDIR%%/html/CommandGuide/llvm-bcanalyzer.html
-%%DOCSDIR%%/html/CommandGuide/llvm-config.html
-%%DOCSDIR%%/html/CommandGuide/llvm-db.html
-%%DOCSDIR%%/html/CommandGuide/llvm-dis.html
-%%DOCSDIR%%/html/CommandGuide/llvm-extract.html
-%%DOCSDIR%%/html/CommandGuide/llvm-ld.html
-%%DOCSDIR%%/html/CommandGuide/llvm-link.html
-%%DOCSDIR%%/html/CommandGuide/llvm-nm.html
-%%DOCSDIR%%/html/CommandGuide/llvm-prof.html
-%%DOCSDIR%%/html/CommandGuide/llvm-ranlib.html
-%%DOCSDIR%%/html/CommandGuide/llvm-upgrade.html
-%%DOCSDIR%%/html/CommandGuide/llvm2cpp.html
-%%DOCSDIR%%/html/CommandGuide/llvmc.html
-%%DOCSDIR%%/html/CommandGuide/llvmgcc.html
-%%DOCSDIR%%/html/CommandGuide/llvmgxx.html
-%%DOCSDIR%%/html/CommandGuide/manpage.css
-%%DOCSDIR%%/html/CommandGuide/opt.html
-%%DOCSDIR%%/html/CommandGuide/stkrc.html
-%%DOCSDIR%%/html/CommandGuide/tblgen.html
-%%DOCSDIR%%/html/CommandLine.html
-%%DOCSDIR%%/html/CompilerDriver.html
-%%DOCSDIR%%/html/CompilerWriterInfo.html
-%%DOCSDIR%%/html/DeveloperPolicy.html
-%%DOCSDIR%%/html/ExceptionHandling.html
-%%DOCSDIR%%/html/ExtendingLLVM.html
-%%DOCSDIR%%/html/FAQ.html
-%%DOCSDIR%%/html/GarbageCollection.html
-%%DOCSDIR%%/html/GetElementPtr.html
-%%DOCSDIR%%/html/GettingStarted.html
-%%DOCSDIR%%/html/GettingStartedVS.html
-%%DOCSDIR%%/html/HowToReleaseLLVM.html
-%%DOCSDIR%%/html/HowToSubmitABug.html
-%%DOCSDIR%%/html/LangRef.html
-%%DOCSDIR%%/html/Lexicon.html
-%%DOCSDIR%%/html/LinkTimeOptimization.html
-%%DOCSDIR%%/html/MakefileGuide.html
-%%DOCSDIR%%/html/Passes.html
-%%DOCSDIR%%/html/ProgrammersManual.html
-%%DOCSDIR%%/html/Projects.html
-%%DOCSDIR%%/html/ReleaseNotes.html
-%%DOCSDIR%%/html/SourceLevelDebugging.html
-%%DOCSDIR%%/html/Stacker.html
-%%DOCSDIR%%/html/SystemLibrary.html
-%%DOCSDIR%%/html/TableGenFundamentals.html
-%%DOCSDIR%%/html/TestingGuide.html
-%%DOCSDIR%%/html/UsingLibraries.html
-%%DOCSDIR%%/html/WritingAnLLVMBackend.html
-%%DOCSDIR%%/html/WritingAnLLVMPass.html
-%%DOCSDIR%%/html/doxygen.css
-%%DOCSDIR%%/html/img/Debugging.gif
-%%DOCSDIR%%/html/img/libdeps.gif
-%%DOCSDIR%%/html/img/lines.gif
-%%DOCSDIR%%/html/img/objdeps.gif
-%%DOCSDIR%%/html/img/venusflytrap.jpg
-%%DOCSDIR%%/html/index.html
-%%DOCSDIR%%/html/llvm.css
-%%DOCSDIR%%/ps/bugpoint.ps
-%%DOCSDIR%%/ps/llc.ps
-%%DOCSDIR%%/ps/lli.ps
-%%DOCSDIR%%/ps/llvm-ar.ps
-%%DOCSDIR%%/ps/llvm-as.ps
-%%DOCSDIR%%/ps/llvm-bcanalyzer.ps
-%%DOCSDIR%%/ps/llvm-config.ps
-%%DOCSDIR%%/ps/llvm-db.ps
-%%DOCSDIR%%/ps/llvm-dis.ps
-%%DOCSDIR%%/ps/llvm-extract.ps
-%%DOCSDIR%%/ps/llvm-ld.ps
-%%DOCSDIR%%/ps/llvm-link.ps
-%%DOCSDIR%%/ps/llvm-nm.ps
-%%DOCSDIR%%/ps/llvm-prof.ps
-%%DOCSDIR%%/ps/llvm-ranlib.ps
-%%DOCSDIR%%/ps/llvm-upgrade.ps
-%%DOCSDIR%%/ps/llvm2cpp.ps
-%%DOCSDIR%%/ps/llvmc.ps
-%%DOCSDIR%%/ps/llvmgcc.ps
-%%DOCSDIR%%/ps/llvmgxx.ps
-%%DOCSDIR%%/ps/opt.ps
-%%DOCSDIR%%/ps/stkrc.ps
-%%DOCSDIR%%/ps/tblgen.ps
-@dirrm include/llvm/Transforms/Utils
-@dirrm include/llvm/Transforms/IPO
-@dirrm include/llvm/Transforms
-@dirrm include/llvm/Target
-@dirrm include/llvm/System
-@dirrm include/llvm/Support
-@dirrm include/llvm/ExecutionEngine
-@dirrm include/llvm/Debugger
-@dirrm include/llvm/Config
-@dirrm include/llvm/CodeGen
-@dirrm include/llvm/Bitcode
-@dirrm include/llvm/Assembly
-@dirrm include/llvm/Analysis
-@dirrm include/llvm/ADT
-@dirrm include/llvm-c
-@dirrm include/llvm
-@dirrm etc/llvm
-@dirrm %%DOCSDIR%%/ps
-@dirrm %%DOCSDIR%%/html/img
-@dirrm %%DOCSDIR%%/html/CommandGuide
-@dirrm %%DOCSDIR%%/html
-@dirrm %%DOCSDIR%%