aboutsummaryrefslogtreecommitdiff
path: root/devel/log4sh
diff options
context:
space:
mode:
Diffstat (limited to 'devel/log4sh')
-rw-r--r--devel/log4sh/Makefile27
-rw-r--r--devel/log4sh/distinfo2
-rw-r--r--devel/log4sh/pkg-descr10
3 files changed, 39 insertions, 0 deletions
diff --git a/devel/log4sh/Makefile b/devel/log4sh/Makefile
new file mode 100644
index 000000000000..b7a26c663a99
--- /dev/null
+++ b/devel/log4sh/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: log4sh
+# Date created: 2005-02-01
+# Whom: David Thiel <lx@redundancy.redundancy.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= log4sh
+PORTVERSION= 1.2.5
+CATEGORIES= devel
+MASTER_SITES= http://forestent.com/dist/log4sh/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= lx@redundancy.redundancy.org
+COMMENT= A common logging library for Bourne shell scripts
+
+PLIST_FILES= lib/log4sh
+PORTDOCS= log4sh.html
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/build/log4sh ${PREFIX}/lib
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/log4sh.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/log4sh/distinfo b/devel/log4sh/distinfo
new file mode 100644
index 000000000000..aed4f0e935a9
--- /dev/null
+++ b/devel/log4sh/distinfo
@@ -0,0 +1,2 @@
+MD5 (log4sh-1.2.5.tgz) = 9a14581c679697d7c8364dd1361ace57
+SIZE (log4sh-1.2.5.tgz) = 33746
diff --git a/devel/log4sh/pkg-descr b/devel/log4sh/pkg-descr
new file mode 100644
index 000000000000..96f701d970a5
--- /dev/null
+++ b/devel/log4sh/pkg-descr
@@ -0,0 +1,10 @@
+Log4sh is a logging framework for shell scripts that works similar to
+the other wonderful logging products available from the Apache Software
+Foundataion (eg. log4j, log4perl). Although not as powerful as the
+others, it can make the task of adding advanced logging to shell scripts
+easier. It has much more power than just using simple "echo" commands
+throughout. In addition, it can be configured from a properties file so
+that scripts in a production environment do not need to be altered to
+change the amount of logging they produce.
+
+WWW: http://forestent.com/products/log4sh/