aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-lacaml/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ocaml-lacaml/Makefile')
-rw-r--r--devel/ocaml-lacaml/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/devel/ocaml-lacaml/Makefile b/devel/ocaml-lacaml/Makefile
index 00e6b754d018..95ddb92c5497 100644
--- a/devel/ocaml-lacaml/Makefile
+++ b/devel/ocaml-lacaml/Makefile
@@ -30,8 +30,8 @@ CFLAGS+= -fPIC
MAKE_ENV+= OCAMLMKLIB_FLAGS="-L${LOCALBASE}/lib"
DOCS= README TODO
-DOCSDIR= ${TARGETDIR}/share/doc/ocaml/${PORTNAME}
-EXAMPLESDIR= ${TARGETDIR}/share/examples/ocaml/${PORTNAME}
+DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
.include <bsd.port.pre.mk>
@@ -53,20 +53,20 @@ post-extract:
post-install:
@${FIND} ${OCAMLFIND_DESTDIR}/${PORTNAME} -type f | \
- ${SED} "s,^${TARGETDIR}/,," >> ${TMPPLIST}
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
@${MKDIR} ${EXAMPLESDIR}
@(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}/)
@${FIND} ${EXAMPLESDIR}/ ! -type d | \
- ${SED} 's,^${TARGETDIR}/,,' >> ${TMPPLIST}
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
@${FIND} ${EXAMPLESDIR}/ -type d | ${SORT} -r | \
- ${SED} 's,^${TARGETDIR}/,@dirrm ,' >> ${TMPPLIST}
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
@${FIND} ${DOCSDIR}/ ! -type d | \
- ${SED} 's,^${TARGETDIR}/,,' >> ${TMPPLIST}
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
@${FIND} ${DOCSDIR}/ -type d | ${SORT} -r | \
- ${SED} 's,^${TARGETDIR}/,@dirrm ,' >> ${TMPPLIST}
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
# XXX: temporary workaround for non-standard PREFIX
@${ECHO_CMD} "@unexec rmdir %D/share/doc/ocaml 2>/dev/null || true" \
>> ${TMPPLIST}