aboutsummaryrefslogtreecommitdiff
path: root/devel/p4p
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p4p')
-rw-r--r--devel/p4p/Makefile151
-rw-r--r--devel/p4p/distinfo.freebsd54x8615
-rw-r--r--devel/p4p/distinfo.freebsd54x86_6415
-rw-r--r--devel/p4p/distinfo.freebsd60x8615
-rw-r--r--devel/p4p/distinfo.freebsd60x86_6415
-rw-r--r--devel/p4p/distinfo.freebsd61sparc6415
-rw-r--r--devel/p4p/distinfo.freebsdaxp6
-rw-r--r--devel/p4p/files/perforce.conf.in75
-rw-r--r--devel/p4p/files/perforce.sh.in61
-rw-r--r--devel/p4p/pkg-descr4
-rw-r--r--devel/p4p/pkg-install51
-rw-r--r--devel/p4p/pkg-plist4
12 files changed, 0 insertions, 427 deletions
diff --git a/devel/p4p/Makefile b/devel/p4p/Makefile
deleted file mode 100644
index 4d0dc8579d2a..000000000000
--- a/devel/p4p/Makefile
+++ /dev/null
@@ -1,151 +0,0 @@
-# New ports collection makefile for: perforce
-# Date created: 3 Mai 2000
-# Whom: sam@inf.enst.fr
-#
-# $FreeBSD$
-#
-
-PORTNAME= perforce
-PORTVERSION= ${VERSION}
-PORTREVISION= ${REVISION}
-PORTEPOCH= 1
-CATEGORIES= devel
-MASTER_SITES= ftp://ftp.perforce.com/pub/perforce/r${PORTVERSION}/bin.${PLATFORM}/ \
- http://filehost.perforce.com/perforce/r${PORTVERSION}/bin.${PLATFORM}/
-EXTRACT_SUFX=
-DISTFILES= ${BIN_FILES} ${SBIN_FILES}
-EXTRACT_ONLY= # none
-
-MAINTAINER= lth@FreeBSD.org
-COMMENT= Perforce client and server
-
-ONLY_FOR_ARCHS= alpha amd64 i386 sparc64
-
-DIST_SUBDIR= perforce/${VERSION}/${ARCH}
-MD5_FILE= ${MASTERDIR}/distinfo.${PLATFORM}
-
-#
-# This is a kludge. I don't know a better way to set PORTVERSION and
-# PORTREVISION such that pkg_version figures out an update is needed
-#
-ARCH!= /usr/bin/uname -p
-ARCH?= i386
-
-.if ${ARCH} == amd64 || ${ARCH} == i386 || ${ARCH} == sparc64
-VERSION= 07.3
-REVISION= 2
-BIN_FILES= p4
-SBIN_FILES= p4d p4ftpd p4p p4web
-REL_NOTES= http://www.perforce.com/perforce/doc.073/user/relnotes.txt
-.elif ${ARCH} == alpha
-VERSION= 99.1
-REVISION= 1
-BIN_FILES= p4
-SBIN_FILES= p4d
-REL_NOTES= http://www.perforce.com/perforce/doc.991/user/relnotes.txt
-.else
-VERSION= 0
-IGNORE= unsupported platform, sorry
-.endif
-
-# End of kludge
-
-RESTRICTED= Restricted distribution
-
-NO_WRKSUBDIR= yes
-
-PLIST_FILES= ${BIN_FILES:S+^+bin/+g} \
- ${SBIN_FILES:S+^+sbin/+g}
-
-.include <bsd.port.pre.mk>
-
-# Figure out what to install
-.if ${ARCH} == alpha
-PLATFORM= freebsdaxp
-.elif ${ARCH} == amd64
-.if ${OSVERSION} >= 504000 && ${OSVERSION} < 600000
-PLATFORM= freebsd54x86_64
-.elif ${OSVERSION} >= 600000
-PLATFORM= freebsd60x86_64
-.endif
-.elif ${ARCH} == i386
-.if ${OSVERSION} >= 504000 && ${OSVERSION} < 600000
-PLATFORM= freebsd54x86
-.elif ${OSVERSION} >= 600000
-PLATFORM= freebsd60x86
-.endif
-.elif ${ARCH} == sparc64 && ${OSVERSION} >= 601000
-PLATFORM= freebsd61sparc64
-.else
-IGNORE= unsupported OS release, sorry
-.endif
-
-.if ${OSVERSION} >= 700043
-LIB_DEPENDS+= c.6:${PORTSDIR}/misc/compat6x
-.endif
-
-# These variables are all configurable.
-PERFORCE_USER?= p4admin
-PERFORCE_UID?= 94
-PERFORCE_GROUP?= p4admin
-PERFORCE_GID?= 94
-PERFORCE_HOME?= ${LOCALBASE}/perforce
-PERFORCE_ROOT?= ${PERFORCE_HOME}/root
-PERFORCE_LOGS?= ${PERFORCE_HOME}/logs
-PERFORCE_PORT?= 1666
-PERFORCE_CACHE?= ${PERFORCE_HOME}/cache
-PERFORCE_TARGET?= perforce:1666
-
-pre-everything::
- @${ECHO} "If the checksums fail, try doing 'make distclean'"
- @${ECHO} "to force getting the latest binaries from Perforce."
- @${ECHO} ""
- @${ECHO} "Read the release notes for this release to determine"
- @${ECHO} "how to migrate the database to the new version. In"
- @${ECHO} "most instances, it is done automatically. However,"
- @${ECHO} "sometimes it must be done manually."
- @${ECHO} ""
- @${ECHO} "The release notes for this version are at"
- @${ECHO} ${REL_NOTES}
- @${ECHO} ""
- @${ECHO} "Checkpoint and backup your data before installing!"
-
-do-build:
- ${SED} -e "s,@PERFORCE_ROOT@,${PERFORCE_ROOT},g" \
- -e "s,@PERFORCE_LOGS@,${PERFORCE_LOGS},g" \
- -e "s,@PERFORCE_USER@,${PERFORCE_USER},g" \
- -e "s,@PERFORCE_PORT@,${PERFORCE_PORT},g" \
- -e "s,@PERFORCE_CACHE@,${PERFORCE_CACHE},g" \
- -e "s,@PERFORCE_TARGET@,${PERFORCE_TARGET},g" \
- < ${FILESDIR}/perforce.conf.in > ${WRKSRC}/perforce.conf
- ${SED} -e "s,@PREFIX@,${PREFIX},g" \
- < ${FILESDIR}/perforce.sh.in > ${WRKSRC}/perforce.sh
-
-pre-su-install:
- ${SETENV} PKG_PREFIX=${PREFIX} \
- PERFORCE_USER=${PERFORCE_USER} \
- PERFORCE_UID=${PERFORCE_UID} \
- PERFORCE_GROUP=${PERFORCE_GROUP} \
- PERFORCE_GID=${PERFORCE_GID} \
- PERFORCE_HOME=${PERFORCE_HOME} \
- PERFORCE_ROOT=${PERFORCE_ROOT} \
- PERFORCE_LOGS=${PERFORCE_LOGS} \
- ${SH} ${PKGDIR}/pkg-install ${PORTNAME} PRE-INSTALL
-
-do-install:
-.for f in ${BIN_FILES}
- ${INSTALL_PROGRAM} ${_DISTDIR}/${f} ${PREFIX}/bin/
-.endfor
-.for f in ${SBIN_FILES}
- ${INSTALL_PROGRAM} ${_DISTDIR}/${f} ${PREFIX}/sbin/
-.endfor
- ${INSTALL_DATA} ${WRKSRC}/perforce.conf ${PREFIX}/etc/perforce.conf.default; \
- if [ ! -f ${PREFIX}/etc/perforce.conf ]; then \
- ${CP} -p ${PREFIX}/etc/perforce.conf.default ${PREFIX}/etc/perforce.conf; \
- fi
- ${INSTALL_SCRIPT} ${WRKSRC}/perforce.sh ${PREFIX}/etc/rc.d/
-
-post-install:
- ${ECHO_CMD} "@unexec ${RMDIR} ${PERFORCE_ROOT} ${PERFORCE_LOGS} ${PERFORCE_HOME} 2>/dev/null || true" >> ${TMPPLIST}
-
-.include <bsd.port.post.mk>
diff --git a/devel/p4p/distinfo.freebsd54x86 b/devel/p4p/distinfo.freebsd54x86
deleted file mode 100644
index 094d657eaeeb..000000000000
--- a/devel/p4p/distinfo.freebsd54x86
+++ /dev/null
@@ -1,15 +0,0 @@
-MD5 (perforce/07.3/i386/p4) = 2cd989467d149b7bd43c03ff7fcd8a51
-SHA256 (perforce/07.3/i386/p4) = 6fe047f7de842ac484d17a0343b2c3f2d2bbf70b1de3709a2401e94689f86c58
-SIZE (perforce/07.3/i386/p4) = 519272
-MD5 (perforce/07.3/i386/p4d) = 5bc4560650641cf8c3019e5cf5f84019
-SHA256 (perforce/07.3/i386/p4d) = 4419a50609263580f498ba4b00383d81bab6f4ab2690c62e90c8b259afb7f42d
-SIZE (perforce/07.3/i386/p4d) = 1508572
-MD5 (perforce/07.3/i386/p4ftpd) = 11375cc50835c475e34aa061cbf4906a
-SHA256 (perforce/07.3/i386/p4ftpd) = 77c39019a9833ff534a48e580f6170f57b0fc4d9f2f3e7cc31028ef96edf57df
-SIZE (perforce/07.3/i386/p4ftpd) = 916553
-MD5 (perforce/07.3/i386/p4p) = cbae23c9949cb0283e527af16ee13285
-SHA256 (perforce/07.3/i386/p4p) = ab5dd647aaabccbaefcf57f1b38a04a68db913f95e50c43ae55b47e30cb2da72
-SIZE (perforce/07.3/i386/p4p) = 473064
-MD5 (perforce/07.3/i386/p4web) = 6d1a9472bc5796904f4895a17c4fe96e
-SHA256 (perforce/07.3/i386/p4web) = e333214fcd23ad5ac9abb03b92f3dceb27bfc05dea87a35fe43e76f2192b28a0
-SIZE (perforce/07.3/i386/p4web) = 2246201
diff --git a/devel/p4p/distinfo.freebsd54x86_64 b/devel/p4p/distinfo.freebsd54x86_64
deleted file mode 100644
index 0f0e8d30bd6c..000000000000
--- a/devel/p4p/distinfo.freebsd54x86_64
+++ /dev/null
@@ -1,15 +0,0 @@
-MD5 (perforce/07.3/amd64/p4) = b1f0661f906830da3fd648c45d363e90
-SHA256 (perforce/07.3/amd64/p4) = da6a4172e3a24804f04df7ce61d9320a7b38c1b56298bb8249c80a0e977a16f1
-SIZE (perforce/07.3/amd64/p4) = 579528
-MD5 (perforce/07.3/amd64/p4d) = eca89bb3e34c4f535e1ee5ba70620964
-SHA256 (perforce/07.3/amd64/p4d) = cda04ac3d43b6235c911cd8fc7bb589bc80ebd604d15cf24efa415707f7821ea
-SIZE (perforce/07.3/amd64/p4d) = 1688616
-MD5 (perforce/07.3/amd64/p4ftpd) = 343d1d7ea997668e4afbf206728be0fb
-SHA256 (perforce/07.3/amd64/p4ftpd) = e1805c8dd97249d3b7095869a77d73797c24c76e2717707e5eb0cfb18daa5536
-SIZE (perforce/07.3/amd64/p4ftpd) = 974539
-MD5 (perforce/07.3/amd64/p4p) = 3c7759ee9b765cef7a1fdc2e44aed410
-SHA256 (perforce/07.3/amd64/p4p) = a0e350876794e2e07f1a242bc2b9b1f7e6ae233368c0442d17dad5a3437f59ed
-SIZE (perforce/07.3/amd64/p4p) = 566344
-MD5 (perforce/07.3/amd64/p4web) = 7446f18d50724e5db46522dd8cedaaeb
-SHA256 (perforce/07.3/amd64/p4web) = 3e5deab8a0f55fb0764e795c1858c1afb8f94c3378c095ca366a0f35bc62cfee
-SIZE (perforce/07.3/amd64/p4web) = 2319744
diff --git a/devel/p4p/distinfo.freebsd60x86 b/devel/p4p/distinfo.freebsd60x86
deleted file mode 100644
index 0c55add8fb5f..000000000000
--- a/devel/p4p/distinfo.freebsd60x86
+++ /dev/null
@@ -1,15 +0,0 @@
-MD5 (perforce/07.3/i386/p4) = ea0f8d86bfe7f86d225e3a871c54f8d4
-SHA256 (perforce/07.3/i386/p4) = a0c6806ccf67ba60c8f85c8d1131e3776d6b02722ed2702b7f89fe7081fe59b8
-SIZE (perforce/07.3/i386/p4) = 519916
-MD5 (perforce/07.3/i386/p4d) = a0ea299963e1e95b0ffc69456d8594f3
-SHA256 (perforce/07.3/i386/p4d) = 333f0c028973a66820f0fd5530532a72d57a6dddad8b238e50045844cd6e5662
-SIZE (perforce/07.3/i386/p4d) = 1517152
-MD5 (perforce/07.3/i386/p4ftpd) = b2d83ebb3aecea264ca9036b28b8eb7f
-SHA256 (perforce/07.3/i386/p4ftpd) = 8341912d704c313a1cf68b98f7c00bd91faab134919465e429121703c13514f4
-SIZE (perforce/07.3/i386/p4ftpd) = 812601
-MD5 (perforce/07.3/i386/p4p) = b80df3f40d448b29e357dc901daf0f19
-SHA256 (perforce/07.3/i386/p4p) = 64fdc6dc97d8c19742da44b1cef74b2efe1625cbde34a207935f0c4cf4e4b6fb
-SIZE (perforce/07.3/i386/p4p) = 477152
-MD5 (perforce/07.3/i386/p4web) = 8305a455c72b2963d085ddc95118c61a
-SHA256 (perforce/07.3/i386/p4web) = 2b04bf576378d37856c27914ee99a4c18c8a44c017fd6d81dd2d8fadb513c1d0
-SIZE (perforce/07.3/i386/p4web) = 2144460
diff --git a/devel/p4p/distinfo.freebsd60x86_64 b/devel/p4p/distinfo.freebsd60x86_64
deleted file mode 100644
index 142869a74df2..000000000000
--- a/devel/p4p/distinfo.freebsd60x86_64
+++ /dev/null
@@ -1,15 +0,0 @@
-MD5 (perforce/07.3/amd64/p4) = 60512b2e37f7d9fab9d7c16dae853f79
-SHA256 (perforce/07.3/amd64/p4) = b7e670119dcb59f77685c90680575385c1c6ef4e08a4998c7308582adeeeb15a
-SIZE (perforce/07.3/amd64/p4) = 587112
-MD5 (perforce/07.3/amd64/p4d) = 4223da0eb4bc03f5984f5420d92a770c
-SHA256 (perforce/07.3/amd64/p4d) = 8a66df1d7dc8f488abdbaae79aa1b1b5bd6ac76fc25511c6d0c21f6259b0d332
-SIZE (perforce/07.3/amd64/p4d) = 1685024
-MD5 (perforce/07.3/amd64/p4ftpd) = d9c8a371a074cb111d9ac6a5b8bf8d4c
-SHA256 (perforce/07.3/amd64/p4ftpd) = e8566db11a5dcc879d425afc43fc4be222be0556a4f4433e353afa791688b69b
-SIZE (perforce/07.3/amd64/p4ftpd) = 873601
-MD5 (perforce/07.3/amd64/p4p) = 051620326a4130c12f7c1a83fc39c7b7
-SHA256 (perforce/07.3/amd64/p4p) = 6b8995d695531eee605fb570947c07f22d8037b5baae60ba25b9480253e52ac2
-SIZE (perforce/07.3/amd64/p4p) = 577632
-MD5 (perforce/07.3/amd64/p4web) = 34c80e3ec0da3f5765efc1d0c0ee706e
-SHA256 (perforce/07.3/amd64/p4web) = 2c9762cef39b4fd547c9dde3bf0e7006252db1eaef0f07ef752b55b2975ecc67
-SIZE (perforce/07.3/amd64/p4web) = 2220526
diff --git a/devel/p4p/distinfo.freebsd61sparc64 b/devel/p4p/distinfo.freebsd61sparc64
deleted file mode 100644
index 235a8a801ffa..000000000000
--- a/devel/p4p/distinfo.freebsd61sparc64
+++ /dev/null
@@ -1,15 +0,0 @@
-MD5 (perforce/07.3/sparc64/p4) = d771d3a59514821f64fe3354ebcf85b3
-SHA256 (perforce/07.3/sparc64/p4) = a692f53cc6b73a53b66a1b97fcbf84eff740f4f0bb65fa30f4f76de568f9ad28
-SIZE (perforce/07.3/sparc64/p4) = 596608
-MD5 (perforce/07.3/sparc64/p4d) = 36361e19fac8a7a46f3641e38e73e627
-SHA256 (perforce/07.3/sparc64/p4d) = 731df4345ebcaa0772a9b780e7008737e662b9096df1a164e6c0e37f2aae2d77
-SIZE (perforce/07.3/sparc64/p4d) = 1700144
-MD5 (perforce/07.3/sparc64/p4ftpd) = f05332cb6a97c780f5fe44091beb5eed
-SHA256 (perforce/07.3/sparc64/p4ftpd) = 7eb10a2dafdc20ab897ab299203a96dbbee04105d36d9071d8d79af407fabf55
-SIZE (perforce/07.3/sparc64/p4ftpd) = 1005411
-MD5 (perforce/07.3/sparc64/p4p) = d3873efb2c4429aa3a148f2d31686b9c
-SHA256 (perforce/07.3/sparc64/p4p) = 8d16eef2c6ce1809c9f805816b2dd801d306dcf267ef9538c6d0dccdb4d07432
-SIZE (perforce/07.3/sparc64/p4p) = 587024
-MD5 (perforce/07.3/sparc64/p4web) = 29863f30c09b77f49a01ad06d5a3679c
-SHA256 (perforce/07.3/sparc64/p4web) = 1e18fab94e68db1a55585642c2c6e342a765d2863e2d7394c3da8c0b400b21db
-SIZE (perforce/07.3/sparc64/p4web) = 2497805
diff --git a/devel/p4p/distinfo.freebsdaxp b/devel/p4p/distinfo.freebsdaxp
deleted file mode 100644
index c770a1d264b8..000000000000
--- a/devel/p4p/distinfo.freebsdaxp
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 (perforce/99.1/alpha/p4) = 7c1300a82ab03b7ede46cf8a02c48fd9
-SHA256 (perforce/99.1/alpha/p4) = 2b9b6c9f161c9f468c079f297058bbb514b48a410907e65a86360f671c4571d0
-SIZE (perforce/99.1/alpha/p4) = 201424
-MD5 (perforce/99.1/alpha/p4d) = 8f34c41c18185011ed848aaf450cffa5
-SHA256 (perforce/99.1/alpha/p4d) = 6d688c995df2c0bd4355ff19158b03931483694ed9fc67055e31eb2c53593841
-SIZE (perforce/99.1/alpha/p4d) = 945544
diff --git a/devel/p4p/files/perforce.conf.in b/devel/p4p/files/perforce.conf.in
deleted file mode 100644
index 803c56f86d17..000000000000
--- a/devel/p4p/files/perforce.conf.in
+++ /dev/null
@@ -1,75 +0,0 @@
-#
-# Perforce FreeBSD configuration file
-#
-#
-# $FreeBSD$
-
-#
-# Perforce ROOT
-#
-PERFORCE_ROOT="@PERFORCE_ROOT@"
-
-#
-# Perforce user (it is recommended to run p4d as a non-root user)
-#
-PERFORCE_USER="@PERFORCE_USER@"
-
-#
-# p4d/p4p port (default: 1666)
-#
-PERFORCE_PORT="@PERFORCE_PORT@"
-
-#
-# p4p cache directory
-#
-PERFORCE_PROXY_CACHE="@PERFORCE_CACHE@"
-
-#
-# p4p target server (default: perforce:1666)
-#
-PERFORCE_PROXY_TARGET="@PERFORCE_TARGET@"
-
-#
-# p4d options (see man p4d)
-#
-PERFORCE_OPTIONS="-d -p $PERFORCE_PORT -v server=1 -L @PERFORCE_LOGS@/p4d.log"
-
-#
-# Uncomment this line to have the server started automatically
-#
-#PERFORCE_START=yes
-
-#
-# p4ftpd options (see p4ftpd -h)
-#
-PERFORCE_FTPD_OPTIONS="-d -p $PERFORCE_PORT -v server=1 -L @PERFORCE_LOGS@/p4ftpd.log"
-
-#
-# Uncomment this line to have the server started automatically
-#
-#PERFORCE_FTPD_START=yes
-
-#
-# p4p options (see p4p -h)
-#
-PERFORCE_PROXY_OPTIONS="-d -p $PERFORCE_PORT -t $PERFORCE_PROXY_TARGET -r $PERFORCE_PROXY_CACHE -v server=1 -L @PERFORCE_LOGS@/p4p.log"
-
-#
-# Uncomment this line to have the proxy server started automatically
-#
-#PERFORCE_PROXY_START=yes
-
-#
-# p4web port
-#
-PERFORCE_WEB_PORT="6060"
-
-#
-# p4web options (see p4web -h)
-#
-PERFORCE_WEB_OPTIONS="-B -w $PERFORCE_WEB_PORT -p $PERFORCE_PORT -v server=1"
-
-#
-# Uncomment this line to have the web server started automatically
-#
-#PERFORCE_WEB_START=yes
diff --git a/devel/p4p/files/perforce.sh.in b/devel/p4p/files/perforce.sh.in
deleted file mode 100644
index 2ebc5809fa48..000000000000
--- a/devel/p4p/files/perforce.sh.in
+++ /dev/null
@@ -1,61 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-
-p4d=@PREFIX@/sbin/p4d
-p4ftpd=@PREFIX@/sbin/p4ftpd
-p4p=@PREFIX@/sbin/p4p
-p4web=@PREFIX@/sbin/p4web
-
-case $1 in
-start)
- [ -f @PREFIX@/etc/perforce.conf ] && . @PREFIX@/etc/perforce.conf
- if [ -x $p4d -a x$PERFORCE_START = xyes ]; then
- echo -n ' p4d'
- su -fm $PERFORCE_USER -c "$p4d -r $PERFORCE_ROOT $PERFORCE_OPTIONS"
- fi
- if [ -x $p4ftpd -a x$PERFORCE_FTPD_START = xyes ]; then
- echo -n ' p4ftpd'
- $p4ftpd $PERFORCE_FTPD_OPTIONS
- fi
- if [ -x $p4p -a x$PERFORCE_PROXY_START = xyes ]; then
- echo -n ' p4p'
- $p4p $PERFORCE_PROXY_OPTIONS
- fi
- if [ -x $p4web -a x$PERFORCE_WEB_START = xyes ]; then
- echo -n ' p4web'
- su -fm $PERFORCE_USER -c "$p4web $PERFORCE_WEB_OPTIONS &" >/dev/null 2>&1
- fi
-
- ;;
-stop)
- [ -f @PREFIX@/etc/perforce.conf ] && . @PREFIX@/etc/perforce.conf
- if [ -x $p4ftpd ]; then
- killall -u 0 p4ftpd >/dev/null 2>&1 && echo -n ' p4ftpd'
- fi
- if [ -x $p4d ]; then
- killall -u $PERFORCE_USER p4d >/dev/null 2>&1 && echo -n ' p4d'
- fi
- if [ -x $p4p ]; then
- killall -u 0 p4p > /dev/null 2>&1 && echo -n ' p4p'
- fi
- if [ -x $p4web ]; then
- killall -u $PERFORCE_USER p4web > /dev/null 2>&1 && echo -n ' p4web'
- fi
- ;;
-restart)
- $0 stop
- sleep 1
- $0 start
- ;;
-checkpoint)
- [ -f @PREFIX@/etc/perforce.conf ] && . @PREFIX@/etc/perforce.conf
- if [ -x $p4d -a x$PERFORCE_START = xyes ]; then
- su -fm $PERFORCE_USER -c "$p4d -r $PERFORCE_ROOT -jc"
- fi
- ;;
-*)
- echo "usage: $0 {start|stop|restart|checkpoint}"
- exit 64
- ;;
-esac
diff --git a/devel/p4p/pkg-descr b/devel/p4p/pkg-descr
deleted file mode 100644
index e6d35851b44b..000000000000
--- a/devel/p4p/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-Perforce is a commercial revision control system that can be used
-gratis for developing free software. (see the WWW page for details).
-
-WWW: http://www.perforce.com/
diff --git a/devel/p4p/pkg-install b/devel/p4p/pkg-install
deleted file mode 100644
index 88b4d17472f4..000000000000
--- a/devel/p4p/pkg-install
+++ /dev/null
@@ -1,51 +0,0 @@
-#! /bin/sh
-#
-# $FreeBSD$
-
-PATH=/bin:/usr/sbin
-
-PERFORCE_USER=${PERFORCE_USER:-p4admin}
-PERFORCE_UID=${PERFORCE_UID:-94}
-PERFORCE_GROUP=${PERFORCE_GROUP:-p4admin}
-PERFORCE_GID=${PERFORCE_GID:-94}
-PERFORCE_HOME=${PERFORCE_HOME:-$PKG_PREFIX/perforce}
-PERFORCE_LOGDIR=${PERFORCE_LOGDIR:-$PERFORCE_HOME/log}
-PERFORCE_ROOT=${PERFORCE_ROOT:-$PERFORCE_HOME/root}
-
-case $2 in
-PRE-INSTALL)
- USER=${PERFORCE_USER}
- GROUP=${PERFORCE_GROUP}
- UID=${PERFORCE_UID}
- GID=${PERFORCE_GID}
-
- if pw group show "${GROUP}" 2>/dev/null; then
- echo "You already have a group \"${GROUP}\", so I will use it."
- else
- if pw groupadd ${GROUP} -g ${GID}; then
- echo "Added group \"${GROUP}\"."
- else
- echo "Adding group \"${GROUP}\" failed..."
- exit 1
- fi
- fi
-
- if pw user show "${USER}" 2>/dev/null; then
- echo "You already have a user \"${USER}\", so I will use it."
- else
- if pw useradd ${USER} -u ${UID} -g ${GROUP} -h - \
- -d ${PERFORCE_HOME} -c "Perforce admin" -s /sbin/nologin
- then
- echo "Added user \"${USER}\"."
- else
- echo "Adding user \"${USER}\" failed..."
- exit 1
- fi
- fi
-
- if [ ! -d $PERFORCE_HOME ] ; then
- mkdir -p $PERFORCE_HOME $PERFORCE_LOGS $PERFORCE_ROOT
- chown -R $USER:$GROUP $PERFORCE_HOME
- fi
- ;;
-esac
diff --git a/devel/p4p/pkg-plist b/devel/p4p/pkg-plist
deleted file mode 100644
index 31e0893152cc..000000000000
--- a/devel/p4p/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-@unexec if cmp -s %D/etc/perforce.conf %D/etc/perforce.conf.default; then rm -f %D/etc/perforce.conf; fi
-etc/perforce.conf.default
-@exec [ ! -f %B/perforce.conf ] && cp -p %B/%f %B/perforce.conf || true
-etc/rc.d/perforce.sh