aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Class-Hook/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Class-Hook/Makefile')
-rw-r--r--devel/p5-Class-Hook/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/p5-Class-Hook/Makefile b/devel/p5-Class-Hook/Makefile
new file mode 100644
index 000000000000..a044c7875626
--- /dev/null
+++ b/devel/p5-Class-Hook/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Class-Hook
+# Date created: Fri Nov 7 19:40:58 EST 2002
+# Whom: Brian Skrab <brian@quynh-and-brian.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Hook
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
+ http://cottage.quynh-and-brian.org/freebsd/ports/distfiles/
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= brian@quynh-and-brian.org
+
+BUILD_DEPENDS= ${SITE_PERL}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+
+PERL_CONFIGURE= yes
+
+MAN3= Class::Hook.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}
+
+.include <bsd.port.mk>