aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Devel-PPPort/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Devel-PPPort/Makefile')
-rw-r--r--devel/p5-Devel-PPPort/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/devel/p5-Devel-PPPort/Makefile b/devel/p5-Devel-PPPort/Makefile
index fba072623504..59e7522f4857 100644
--- a/devel/p5-Devel-PPPort/Makefile
+++ b/devel/p5-Devel-PPPort/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= Devel-PPPort
-PORTVERSION= 3.03
+PORTVERSION= 3.04
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= Devel/MHX
+MASTER_SITE_SUBDIR= Devel
PKGNAMEPREFIX= p5-
#DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.(..)$/_\1/}
@@ -21,4 +21,13 @@ CONFIGURE_ARGS= INSTALLDIRS=site
MAN3= Devel::PPPort.3
+.if !defined(NOPORTDOCS)
+PORTDOCS= Changes README HACKERS TODO
+
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
.include <bsd.port.mk>