aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-IO-Tty
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-IO-Tty')
-rw-r--r--devel/p5-IO-Tty/Makefile25
-rw-r--r--devel/p5-IO-Tty/distinfo1
-rw-r--r--devel/p5-IO-Tty/pkg-comment1
-rw-r--r--devel/p5-IO-Tty/pkg-descr4
-rw-r--r--devel/p5-IO-Tty/pkg-plist10
5 files changed, 41 insertions, 0 deletions
diff --git a/devel/p5-IO-Tty/Makefile b/devel/p5-IO-Tty/Makefile
new file mode 100644
index 000000000000..c5ccd033c19c
--- /dev/null
+++ b/devel/p5-IO-Tty/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-IO-Tty
+# Version required: 0.02
+# Date created: 14 Jan 2000
+# Whom: Will Andrews <andrews@technologist.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= IO-Tty-0.02
+PKGNAME= p5-IO-Tty-0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IO
+
+MAINTAINER= andrews@technologist.com
+
+USE_PERL5= yes
+IS_INTERACTIVE= yes
+MAN3= IO::Pty.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL LDDLFLAGS=-shared LDFLAGS=-L/usr/lib)
+
+.include <bsd.port.mk>
diff --git a/devel/p5-IO-Tty/distinfo b/devel/p5-IO-Tty/distinfo
new file mode 100644
index 000000000000..3439753e947b
--- /dev/null
+++ b/devel/p5-IO-Tty/distinfo
@@ -0,0 +1 @@
+MD5 (IO-Tty-0.02.tar.gz) = f749a643e9aed022551efadf94a7a5ae
diff --git a/devel/p5-IO-Tty/pkg-comment b/devel/p5-IO-Tty/pkg-comment
new file mode 100644
index 000000000000..5085fe247cd3
--- /dev/null
+++ b/devel/p5-IO-Tty/pkg-comment
@@ -0,0 +1 @@
+Flexible I/O Perl5 module that allows manipulation of pseudo-TTYs
diff --git a/devel/p5-IO-Tty/pkg-descr b/devel/p5-IO-Tty/pkg-descr
new file mode 100644
index 000000000000..5d650fb8f5e5
--- /dev/null
+++ b/devel/p5-IO-Tty/pkg-descr
@@ -0,0 +1,4 @@
+Perl5 module that allows creation of pseudo-tty's
+as well as manipulation.
+
+--Will <andrews@technologist.com>
diff --git a/devel/p5-IO-Tty/pkg-plist b/devel/p5-IO-Tty/pkg-plist
new file mode 100644
index 000000000000..5127383f1f2a
--- /dev/null
+++ b/devel/p5-IO-Tty/pkg-plist
@@ -0,0 +1,10 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Tty/Tty.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Tty/Tty.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Tty/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/IO/Pty.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/IO/Tty.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Tty
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/IO 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%% 2>/dev/null || true