aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-POE/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-POE/Makefile')
-rw-r--r--devel/p5-POE/Makefile29
1 files changed, 16 insertions, 13 deletions
diff --git a/devel/p5-POE/Makefile b/devel/p5-POE/Makefile
index 3593d2ef435a..0c75f355127f 100644
--- a/devel/p5-POE/Makefile
+++ b/devel/p5-POE/Makefile
@@ -6,23 +6,23 @@
#
PORTNAME= POE
-PORTVERSION= 0.23
+PORTVERSION= 0.25
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} http://poe.perl.org/poedown/
MASTER_SITE_SUBDIR= POE
PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
+COMMENT= Multitasking and networking framework for perl
BUILD_DEPENDS= \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Event.pm:${PORTSDIR}/devel/p5-Event \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Filter/Util/Call.pm:${PORTSDIR}/devel/p5-Filter \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+ ${SITE_PERL}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
+ ${SITE_PERL}/${PERL_ARCH}/Event.pm:${PORTSDIR}/devel/p5-Event \
+ ${SITE_PERL}/${PERL_ARCH}/Filter/Util/Call.pm:${PORTSDIR}/devel/p5-Filter \
+ ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
RUN_DEPENDS= ${BUILD_DEPENDS}
-PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
PERL_CONFIGURE= yes
CONFIGURE_ARGS= </dev/null
@@ -33,18 +33,21 @@ MAN3= POE.3 POE::Component.3 POE::Component::Client::TCP.3 \
POE::Filter::Grep.3 POE::Filter::HTTPD.3 POE::Filter::Line.3 \
POE::Filter::Map.3 POE::Filter::RecordBlock.3 \
POE::Filter::Reference.3 POE::Filter::Stackable.3 \
- POE::Filter::Stream.3 POE::Kernel.3 POE::NFA.3 POE::Pipe.3 \
+ POE::Filter::Stream.3 POE::Kernel.3 POE::Loop.3 \
+ POE::Loop::Event.3 POE::Loop::Gtk.3 POE::Loop::Poll.3 \
+ POE::Loop::Select.3 POE::Loop::Tk.3 POE::NFA.3 POE::Pipe.3 \
POE::Pipe::OneWay.3 POE::Pipe::TwoWay.3 POE::Preprocessor.3 \
- POE::Session.3 POE::Wheel.3 POE::Wheel::Curses.3 \
- POE::Wheel::FollowTail.3 POE::Wheel::ListenAccept.3 \
- POE::Wheel::ReadLine.3 POE::Wheel::ReadWrite.3 \
- POE::Wheel::Run.3 POE::Wheel::SocketFactory.3
+ POE::Queue.3 POE::Queue::Array.3 POE::Session.3 POE::Wheel.3 \
+ POE::Wheel::Curses.3 POE::Wheel::FollowTail.3 \
+ POE::Wheel::ListenAccept.3 POE::Wheel::ReadLine.3 \
+ POE::Wheel::ReadWrite.3 POE::Wheel::Run.3 \
+ POE::Wheel::SocketFactory.3
post-install:
.ifndef(NOPORTDOCS)
@${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
@${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/samples/* ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/samples/* ${EXAMPLESDIR}
.endif
.include <bsd.port.mk>