aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Sub-Name/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Sub-Name/Makefile')
-rw-r--r--devel/p5-Sub-Name/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/p5-Sub-Name/Makefile b/devel/p5-Sub-Name/Makefile
new file mode 100644
index 000000000000..e6d848a949e1
--- /dev/null
+++ b/devel/p5-Sub-Name/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: devel/p5-Sub-Name
+# Date created: 27 November 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sub-Name
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Sub
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Sub::Name - (re)name a sub
+
+PERL_CONFIGURE= yes
+
+MAN3= Sub::Name.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>