aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Class/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Test-Class/Makefile')
-rw-r--r--devel/p5-Test-Class/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/devel/p5-Test-Class/Makefile b/devel/p5-Test-Class/Makefile
index fc2bf5fb1274..c42932ff0db6 100644
--- a/devel/p5-Test-Class/Makefile
+++ b/devel/p5-Test-Class/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@FreeBSD.org
COMMENT= Test::Class - Easily create test classes in an xUnit style
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Builder-Tester \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Differences.pm:${PORTSDIR}/devel/p5-Test-Differences
+BUILD_DEPENDS= ${SITE_PERL}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Builder-Tester \
+ ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
+ ${SITE_PERL}/Test/Differences.pm:${PORTSDIR}/devel/p5-Test-Differences
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -34,14 +34,14 @@ IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
.endif
.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Attribute/Handlers.pm:${PORTSDIR}/devel/p5-Attribute-Handlers
-RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Attribute/Handlers.pm:${PORTSDIR}/devel/p5-Attribute-Handlers
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${SITE_PERL}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA \
+ ${SITE_PERL}/Attribute/Handlers.pm:${PORTSDIR}/devel/p5-Attribute-Handlers
+RUN_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${SITE_PERL}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA \
+ ${SITE_PERL}/Attribute/Handlers.pm:${PORTSDIR}/devel/p5-Attribute-Handlers
.endif
.include <bsd.port.post.mk>