aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Tree-Simple/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Tree-Simple/Makefile')
-rw-r--r--devel/p5-Tree-Simple/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/devel/p5-Tree-Simple/Makefile b/devel/p5-Tree-Simple/Makefile
index d958307627ef..fc5a0dca7994 100644
--- a/devel/p5-Tree-Simple/Makefile
+++ b/devel/p5-Tree-Simple/Makefile
@@ -19,4 +19,11 @@ PERL_CONFIGURE= yes
MAN3= Tree::Simple.3 Tree::Simple::Visitor.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>