aboutsummaryrefslogtreecommitdiff
path: root/devel/pkg-config/files
diff options
context:
space:
mode:
Diffstat (limited to 'devel/pkg-config/files')
-rw-r--r--devel/pkg-config/files/patch-Makefile.in23
-rw-r--r--devel/pkg-config/files/patch-glib-1.2.8::Makefile.in14
-rw-r--r--devel/pkg-config/files/patch-ltmain.sh28
-rw-r--r--devel/pkg-config/files/patch-parse.c34
-rw-r--r--devel/pkg-config/files/patch-pkg.c32
5 files changed, 0 insertions, 131 deletions
diff --git a/devel/pkg-config/files/patch-Makefile.in b/devel/pkg-config/files/patch-Makefile.in
deleted file mode 100644
index c0e58c620757..000000000000
--- a/devel/pkg-config/files/patch-Makefile.in
+++ /dev/null
@@ -1,23 +0,0 @@
-
-$FreeBSD$
-
---- Makefile.in.orig Sun Feb 3 20:23:27 2002
-+++ Makefile.in Thu Feb 7 11:46:04 2002
-@@ -35,7 +35,7 @@
- DESTDIR =
-
- pkgdatadir = $(datadir)/@PACKAGE@
--pkglibdir = $(libdir)/@PACKAGE@
-+pkglibdir = $(prefix)/libdata/@PACKAGE@
- pkgincludedir = $(includedir)/@PACKAGE@
-
- top_builddir = .
-@@ -91,7 +91,7 @@
-
- bin_PROGRAMS = pkg-config
-
--INCLUDES = -DPKGLIBDIR="\"$(pkglibdir)\"" $(included_glib_includes)
-+INCLUDES = -DPKGLIBDIR="\"$(pkglibdir)\"" -DXPKGLIBDIR="\"$(X11BASE)/libdata/@PACKAGE@\"" -DLPKGLIBDIR="\"$(LOCALBASE)/libdata/@PACKAGE@\"" $(included_glib_includes)
-
- pkg_config_SOURCES = \
- pkg.h \
diff --git a/devel/pkg-config/files/patch-glib-1.2.8::Makefile.in b/devel/pkg-config/files/patch-glib-1.2.8::Makefile.in
deleted file mode 100644
index f789c923658a..000000000000
--- a/devel/pkg-config/files/patch-glib-1.2.8::Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- glib-1.2.8/Makefile.in.orig Thu Jul 12 03:45:31 2001
-+++ glib-1.2.8/Makefile.in Wed Aug 1 10:42:44 2001
-@@ -501,7 +501,7 @@
-
- install-am: all-am
- @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
--install: install-recursive
-+install:
- uninstall-am:
- uninstall: uninstall-recursive
- all-am: Makefile $(LTLIBRARIES) $(PROGRAMS) $(SCRIPTS) $(DATA) \
diff --git a/devel/pkg-config/files/patch-ltmain.sh b/devel/pkg-config/files/patch-ltmain.sh
deleted file mode 100644
index 98cb05e4ddb3..000000000000
--- a/devel/pkg-config/files/patch-ltmain.sh
+++ /dev/null
@@ -1,28 +0,0 @@
-
-$FreeBSD$
-
---- ltmain.sh 2001/08/27 09:51:26 1.1
-+++ ltmain.sh 2001/08/27 09:51:42
-@@ -2408,6 +2408,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4175,10 +4178,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/pkg-config/files/patch-parse.c b/devel/pkg-config/files/patch-parse.c
deleted file mode 100644
index b591663c5709..000000000000
--- a/devel/pkg-config/files/patch-parse.c
+++ /dev/null
@@ -1,34 +0,0 @@
-
-$FreeBSD$
-
---- parse.c 2001/08/01 07:24:17 1.1
-+++ parse.c 2001/08/01 07:25:02
-@@ -952,9 +952,9 @@
- {
- char *output;
-
-- debug_spew ("Calling glib-config\n");
-+ debug_spew ("Calling glib12-config\n");
-
-- pkg->version = backticks ("glib-config --version");
-+ pkg->version = backticks ("glib12-config --version");
- if (pkg->version == NULL)
- {
- g_free (pkg);
-@@ -965,12 +965,12 @@
- pkg->key = g_strdup ("glib");
- pkg->description = g_strdup ("C Utility Library");
-
-- output = backticks ("glib-config --libs");
-- parse_libs (pkg, output, "glib-config");
-+ output = backticks ("glib12-config --libs");
-+ parse_libs (pkg, output, "glib12-config");
- g_free (output);
-
-- output = backticks ("glib-config --cflags");
-- parse_cflags (pkg, output, "glib-config");
-+ output = backticks ("glib12-config --cflags");
-+ parse_cflags (pkg, output, "glib12-config");
- g_free (output);
-
- return pkg;
diff --git a/devel/pkg-config/files/patch-pkg.c b/devel/pkg-config/files/patch-pkg.c
deleted file mode 100644
index f928ebc29910..000000000000
--- a/devel/pkg-config/files/patch-pkg.c
+++ /dev/null
@@ -1,32 +0,0 @@
---- pkg.c.orig Thu Jan 16 16:07:09 2003
-+++ pkg.c Wed Jan 22 18:11:41 2003
-@@ -113,7 +113,7 @@
- * locations, ignoring duplicates
- */
- static void
--scan_dir (const char *dirname)
-+scan_dir (const char *dirname, void *quiet)
- {
- DIR *dir;
- struct dirent *dent;
-@@ -133,7 +133,8 @@
- free (dirname_copy);
- if (!dir)
- {
-- debug_spew ("Cannot open directory '%s' in package search path: %s\n",
-+ if (!quiet)
-+ debug_spew ("Cannot open directory '%s' in package search path: %s\n",
- dirname, g_strerror (errno));
- return;
- }
-@@ -202,7 +203,9 @@
- path_positions = g_hash_table_new (g_str_hash, g_str_equal);
-
- g_slist_foreach (search_dirs, (GFunc)scan_dir, NULL);
-- scan_dir (pkglibdir);
-+ scan_dir (pkglibdir, (void *)0);
-+ scan_dir (XPKGLIBDIR, (void *)1);
-+ scan_dir (LPKGLIBDIR, (void *)1);
- }
- }
-