aboutsummaryrefslogtreecommitdiff
path: root/devel/pkg-config
diff options
context:
space:
mode:
Diffstat (limited to 'devel/pkg-config')
-rw-r--r--devel/pkg-config/Makefile31
-rw-r--r--devel/pkg-config/distinfo1
-rw-r--r--devel/pkg-config/files/patch-Makefile.in23
-rw-r--r--devel/pkg-config/files/patch-glib-1.2.8::Makefile.in14
-rw-r--r--devel/pkg-config/files/patch-ltmain.sh28
-rw-r--r--devel/pkg-config/files/patch-parse.c34
-rw-r--r--devel/pkg-config/files/patch-pkg.c35
-rw-r--r--devel/pkg-config/pkg-comment1
-rw-r--r--devel/pkg-config/pkg-descr19
-rw-r--r--devel/pkg-config/pkg-plist6
10 files changed, 0 insertions, 192 deletions
diff --git a/devel/pkg-config/Makefile b/devel/pkg-config/Makefile
deleted file mode 100644
index 1cf141eae423..000000000000
--- a/devel/pkg-config/Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
-# New ports collection makefile for: pkgconfig
-# Date created: 30 April 2001
-# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= pkgconfig
-PORTVERSION= 0.8.0
-CATEGORIES= devel
-MASTER_SITES= http://www.freedesktop.org/software/pkgconfig/releases/ \
- ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-
-MAINTAINER= gnome@FreeBSD.org
-
-USE_GMAKE= yes
-USE_LIBTOOL= yes
-LIBTOOLFILES= glib-1.2.8/configure
-LIBTOOLFLAGS= --disable-ltlibs \
- --disable-shared
-MAKE_ENV= PKGCONF_BUILD=yes
-
-PLIST_SUB= LOCALBASE=${LOCALBASE} X11BASE=${X11BASE}
-
-MAN1= pkg-config.1
-
-post-install:
- ${MKDIR} ${PREFIX}/libdata/pkgconfig
-
-.include <bsd.port.mk>
diff --git a/devel/pkg-config/distinfo b/devel/pkg-config/distinfo
deleted file mode 100644
index 5c9080f54d64..000000000000
--- a/devel/pkg-config/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (pkgconfig-0.8.0.tar.gz) = e110ee9635fbc0ec159c440c75876a96
diff --git a/devel/pkg-config/files/patch-Makefile.in b/devel/pkg-config/files/patch-Makefile.in
deleted file mode 100644
index 75cdeb89ca3a..000000000000
--- a/devel/pkg-config/files/patch-Makefile.in
+++ /dev/null
@@ -1,23 +0,0 @@
-
-$FreeBSD$
-
---- Makefile.in.orig Wed Jan 3 11:39:15 2001
-+++ Makefile.in Sun Apr 29 14:40:59 2001
-@@ -35,7 +35,7 @@
- DESTDIR =
-
- pkgdatadir = $(datadir)/@PACKAGE@
--pkglibdir = $(libdir)/@PACKAGE@
-+pkglibdir = $(prefix)/libdata/@PACKAGE@
- pkgincludedir = $(includedir)/@PACKAGE@
-
- top_builddir = .
-@@ -81,7 +81,7 @@
-
- bin_PROGRAMS = pkg-config
-
--INCLUDES = -DPKGLIBDIR="\"$(pkglibdir)\"" -I./glib-1.2.8
-+INCLUDES = -DPKGLIBDIR="\"$(pkglibdir)\"" -DXPKGLIBDIR="\"$(X11BASE)/libdata/@PACKAGE@\"" -DLPKGLIBDIR="\"$(LOCALBASE)/libdata/@PACKAGE@\"" -I./glib-1.2.8
-
- pkg_config_SOURCES = pkg.h pkg.c partial-glib.h partial-glib.c parse.h parse.c main.c findme.c findme.h popt.c popt.h poptconfig.c popthelp.c poptint.h poptparse.c
-
diff --git a/devel/pkg-config/files/patch-glib-1.2.8::Makefile.in b/devel/pkg-config/files/patch-glib-1.2.8::Makefile.in
deleted file mode 100644
index f789c923658a..000000000000
--- a/devel/pkg-config/files/patch-glib-1.2.8::Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- glib-1.2.8/Makefile.in.orig Thu Jul 12 03:45:31 2001
-+++ glib-1.2.8/Makefile.in Wed Aug 1 10:42:44 2001
-@@ -501,7 +501,7 @@
-
- install-am: all-am
- @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
--install: install-recursive
-+install:
- uninstall-am:
- uninstall: uninstall-recursive
- all-am: Makefile $(LTLIBRARIES) $(PROGRAMS) $(SCRIPTS) $(DATA) \
diff --git a/devel/pkg-config/files/patch-ltmain.sh b/devel/pkg-config/files/patch-ltmain.sh
deleted file mode 100644
index 98cb05e4ddb3..000000000000
--- a/devel/pkg-config/files/patch-ltmain.sh
+++ /dev/null
@@ -1,28 +0,0 @@
-
-$FreeBSD$
-
---- ltmain.sh 2001/08/27 09:51:26 1.1
-+++ ltmain.sh 2001/08/27 09:51:42
-@@ -2408,6 +2408,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4175,10 +4178,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/pkg-config/files/patch-parse.c b/devel/pkg-config/files/patch-parse.c
deleted file mode 100644
index b591663c5709..000000000000
--- a/devel/pkg-config/files/patch-parse.c
+++ /dev/null
@@ -1,34 +0,0 @@
-
-$FreeBSD$
-
---- parse.c 2001/08/01 07:24:17 1.1
-+++ parse.c 2001/08/01 07:25:02
-@@ -952,9 +952,9 @@
- {
- char *output;
-
-- debug_spew ("Calling glib-config\n");
-+ debug_spew ("Calling glib12-config\n");
-
-- pkg->version = backticks ("glib-config --version");
-+ pkg->version = backticks ("glib12-config --version");
- if (pkg->version == NULL)
- {
- g_free (pkg);
-@@ -965,12 +965,12 @@
- pkg->key = g_strdup ("glib");
- pkg->description = g_strdup ("C Utility Library");
-
-- output = backticks ("glib-config --libs");
-- parse_libs (pkg, output, "glib-config");
-+ output = backticks ("glib12-config --libs");
-+ parse_libs (pkg, output, "glib12-config");
- g_free (output);
-
-- output = backticks ("glib-config --cflags");
-- parse_cflags (pkg, output, "glib-config");
-+ output = backticks ("glib12-config --cflags");
-+ parse_cflags (pkg, output, "glib12-config");
- g_free (output);
-
- return pkg;
diff --git a/devel/pkg-config/files/patch-pkg.c b/devel/pkg-config/files/patch-pkg.c
deleted file mode 100644
index 3bf9b3f766bf..000000000000
--- a/devel/pkg-config/files/patch-pkg.c
+++ /dev/null
@@ -1,35 +0,0 @@
-
-$FreeBSD$
-
---- pkg.c.orig Mon May 28 16:02:53 2001
-+++ pkg.c Wed Jul 11 14:42:22 2001
-@@ -71,7 +71,7 @@
- * locations, ignoring duplicates
- */
- static void
--scan_dir (const char *dirname)
-+scan_dir (const char *dirname, void *quiet)
- {
- DIR *dir = opendir (dirname);
- struct dirent *dent;
-@@ -82,7 +82,8 @@
-
- if (!dir)
- {
-- debug_spew ("Cannot open directory '%s' in package search path: %s\n",
-+ if (!quiet)
-+ debug_spew ("Cannot open directory '%s' in package search path: %s\n",
- dirname, g_strerror (errno));
- return;
- }
-@@ -141,7 +142,9 @@
- locations = g_hash_table_new (g_str_hash, g_str_equal);
-
- g_slist_foreach (search_dirs, (GFunc)scan_dir, NULL);
-- scan_dir (PKGLIBDIR);
-+ scan_dir (PKGLIBDIR, (void *)0);
-+ scan_dir (XPKGLIBDIR, (void *)1);
-+ scan_dir (LPKGLIBDIR, (void *)1);
- }
- }
-
diff --git a/devel/pkg-config/pkg-comment b/devel/pkg-config/pkg-comment
deleted file mode 100644
index 693e559de028..000000000000
--- a/devel/pkg-config/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-An utility used to retrieve information about installed libraries
diff --git a/devel/pkg-config/pkg-descr b/devel/pkg-config/pkg-descr
deleted file mode 100644
index f61c1700ec07..000000000000
--- a/devel/pkg-config/pkg-descr
+++ /dev/null
@@ -1,19 +0,0 @@
-The pkg-config program is used to retrieve information about installed
-libraries in the system. It is typically used to compile and link against one
-or more libraries.
-
-pkg-config retrieves information about packages from special metadata files.
-These files are named after the package, with the extension .pc. By default,
-pkg-config looks in the following directories: ${PREFIX}/libdata/pkgconfig,
-${LOCALBASE}/libdata/pkgconfig and ${X11BASE}/libdata/pkgconfig for these
-files; it will also look in the list of directories specified by the
-PKG_CONFIG_PATH environment variable.
-
-The package name specified on the pkg-config command line is defined to be the
-name of the metadata file, minus the .pc extension. If a library can install
-multiple versions simultaneously, it must give each version its own name (for
-example, GTK 1.2 might have the package name "gtk+" while GTK 2.0 has
-"gtk+-2.0").
-
-WWW: http://www.freedesktop.org/software/pkgconfig/
- http://pkgconfig.sourceforge.net
diff --git a/devel/pkg-config/pkg-plist b/devel/pkg-config/pkg-plist
deleted file mode 100644
index 95e761321f78..000000000000
--- a/devel/pkg-config/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-@exec mkdir -p %D/libdata/pkgconfig
-bin/pkg-config
-share/aclocal/pkg.m4
-@dirrm libdata/pkgconfig
-@unexec rmdir %%LOCALBASE%%/libdata/pkgconfig 2>/dev/null || true
-@unexec rmdir %%X11BASE%%/libdata/pkgconfig 2>/dev/null || true