aboutsummaryrefslogtreecommitdiff
path: root/devel/portlint/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/portlint/Makefile')
-rw-r--r--devel/portlint/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/devel/portlint/Makefile b/devel/portlint/Makefile
index fac1be4e1dee..5b788582c495 100644
--- a/devel/portlint/Makefile
+++ b/devel/portlint/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= portlint
-PORTVERSION= 2.4.8
+PORTVERSION= 2.5.0
CATEGORIES= devel
MASTER_SITES= # none
DISTFILES= # none
@@ -33,9 +33,13 @@ pre-patch:
post-patch:
@${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/portlint.pl
+ @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' \
+ ${WRKSRC}/portlintgrep.pl
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/portlint.pl ${PREFIX}/bin/portlint
${INSTALL_MAN} ${WRKSRC}/portlint.1 ${MAN1PREFIX}/man/man1
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/portlintgrep.pl ${EXAMPLESDIR}/portlintgrep
.include <bsd.port.mk>