aboutsummaryrefslogtreecommitdiff
path: root/devel/portlint
diff options
context:
space:
mode:
Diffstat (limited to 'devel/portlint')
-rw-r--r--devel/portlint/Makefile1
-rw-r--r--devel/portlint/src/portlint.pl5
2 files changed, 4 insertions, 2 deletions
diff --git a/devel/portlint/Makefile b/devel/portlint/Makefile
index 7699bd3b4e6c..06b2435281aa 100644
--- a/devel/portlint/Makefile
+++ b/devel/portlint/Makefile
@@ -9,6 +9,7 @@
PORTNAME= portlint
PORTVERSION= 2.4.5
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= # none
DISTFILES= # none
diff --git a/devel/portlint/src/portlint.pl b/devel/portlint/src/portlint.pl
index af650b73252b..8b320ffb29bd 100644
--- a/devel/portlint/src/portlint.pl
+++ b/devel/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $Id: portlint.pl,v 1.18 2003/10/26 21:24:08 marcus Exp $
+# $Id: portlint.pl,v 1.19 2003/10/27 01:57:35 marcus Exp $
#
use vars qw/ $opt_a $opt_A $opt_b $opt_c $opt_h $opt_t $opt_v $opt_M $opt_N $opt_B $opt_V /;
@@ -903,7 +903,8 @@ sub checkmakefile {
if ($whole =~ /NOPORTSDOC/) {
&perror("WARN: NOPORTSDOC found. Do you mean NOPORTDOCS?");
}
- if ($sharedocused && $whole !~ /defined\(NOPORTDOCS\)/
+ if ($sharedocused && $whole !~ /defined\s*\(NOPORTDOCS\)/
+ && $whole !~ /def\s*\(NOPORTDOCS\)/
&& $whole !~ m#(\$[\{\(]PREFIX[\}\)]|$localbase)/share/doc#) {
&perror("WARN: use \".if !defined(NOPORTDOCS)\" to wrap ".
"installation of files into $localbase/share/doc.");