aboutsummaryrefslogtreecommitdiff
path: root/devel/py-cxx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-cxx/Makefile')
-rw-r--r--devel/py-cxx/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/devel/py-cxx/Makefile b/devel/py-cxx/Makefile
new file mode 100644
index 000000000000..ec5efd8101c6
--- /dev/null
+++ b/devel/py-cxx/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# New ports collection makefile for: PyCXX
+# Date created: Oct 7, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= cxx
+PORTVERSION= 5.1r1
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyCXX-V${PORTVERSION:S/r/-rc/}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PYTHON= yes
+SETUP_CMD= cd ${WRKSRC} && ${PYTHON_CMD} setup.py
+
+do-build:
+ @${SETUP_CMD} build
+
+do-install:
+ @${SETUP_CMD} install
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Doc/PyCXX.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>