aboutsummaryrefslogtreecommitdiff
path: root/devel/py-mwlib.rl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-mwlib.rl/Makefile')
-rw-r--r--devel/py-mwlib.rl/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/py-mwlib.rl/Makefile b/devel/py-mwlib.rl/Makefile
new file mode 100644
index 000000000000..3f89c2d4eae2
--- /dev/null
+++ b/devel/py-mwlib.rl/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: mwlib.rl
+# Date created: 06 May, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mwlib.rl
+PORTVERSION= 0.11.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Generate Pdfs from Mediawiki Markup
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/texvc:${PORTSDIR}/print/texvc \
+ ${LOCALBASE}/bin/fribidi:${PORTSDIR}/converters/fribidi \
+ ${PYTHON_PKGNAMEPREFIX}mwlib>=0.11.1:${PORTSDIR}/devel/py-mwlib \
+ ${PYTHON_PKGNAMEPREFIX}mwlib.ext>=0.9.3:${PORTSDIR}/devel/py-mwlib.ext \
+ ${PYTHON_PKGNAMEPREFIX}pygments>=1.0:${PORTSDIR}/textproc/py-pygments
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_GETTEXT= yes
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>