aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-daemons/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/rubygem-daemons/Makefile')
-rw-r--r--devel/rubygem-daemons/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/rubygem-daemons/Makefile b/devel/rubygem-daemons/Makefile
new file mode 100644
index 000000000000..bd056911dbd4
--- /dev/null
+++ b/devel/rubygem-daemons/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: daemons
+# Date created: 20 May 2006
+# Whom: Rui Lopes (<rgl ruilopes com>)
+#
+# $FreeBSD$
+
+PORTNAME= daemons
+PORTVERSION= 0.4.4
+CATEGORIES= devel rubygems
+MASTER_SITES= http://rubyforge.org/frs/download.php/9598/
+
+MAINTAINER= rgl@ruilopes.com
+COMMENT= A toolkit to convert your script to a controllable daemon
+
+# This target is only meant to be used by the port maintainer.
+x-generate-plist:
+ (${PORTSDIR}/Tools/scripts/plist -d -m ${MTREE_FILE} ${PREFIX} \
+ | ${SED} -E \
+ 's,.*share/nls/.+$$,,g \
+ ;s,^${CACHE_DIR}(/.+)$$,%%CACHE_DIR%%\1,g \
+ ;s,${GEM_DOC_DIR}(/.+)?$$,%%GEM_DOC_DIR%%\1,g \
+ ;s,${GEM_LIB_DIR}(/.+)?$$,%%GEM_LIB_DIR%%\1,g \
+ ;s,^${SPEC_DIR}(/.+)$$,%%SPEC_DIR%%\1,g \
+ ;s,^${GEMS_BASE_DIR}/(.+)$$,\1,g \
+ ;s,^@dirrm (${SPEC_DIR}|${GEMS_DIR}|lib/ruby).*$$,,g \
+ ' | ${TR} -s '\n') > temp-pkg-plist
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
+.include <bsd.port.post.mk>