aboutsummaryrefslogtreecommitdiff
path: root/devel/swig20/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/swig20/Makefile')
-rw-r--r--devel/swig20/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/devel/swig20/Makefile b/devel/swig20/Makefile
index 0319d89057e9..4e9e08b7eec5 100644
--- a/devel/swig20/Makefile
+++ b/devel/swig20/Makefile
@@ -6,18 +6,16 @@
#
PORTNAME= swig
-PORTVERSION= ${VER}a5
-PORTREVISION= 6
+PORTVERSION= 1.3.6
CATEGORIES= devel perl5 python ruby tcl82
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.rge.com/pub/languages/swig/ \
ftp://ftp.mcc.ac.uk/pub/mvc/swig/
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= knu@FreeBSD.org
-VER= 1.3
+VER= ${PORTVERSION:R}
SWIG_LANGUAGES?= guile perl python ruby tcl
.for lang in ${SWIG_LANGUAGES}
@@ -48,7 +46,7 @@ CONFIGURE_ARGS+= --with-tclincl=${LOCALBASE}/include/tcl8.2/ \
.endif
INSTALLS_SHLIB= yes
-WRKSRC= ${WRKDIR}/SWIG${PORTVERSION}
+WRKSRC= ${WRKDIR}/${DISTNAME:U}
USE_LIBTOOL= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -fpic -DPIC"
ALL_TARGET= swig runtime