aboutsummaryrefslogtreecommitdiff
path: root/devel/t1lib
diff options
context:
space:
mode:
Diffstat (limited to 'devel/t1lib')
-rw-r--r--devel/t1lib/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/devel/t1lib/Makefile b/devel/t1lib/Makefile
index 9d9cb4a0af18..566a36f411d2 100644
--- a/devel/t1lib/Makefile
+++ b/devel/t1lib/Makefile
@@ -20,7 +20,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A Type 1 Rasterizer Library for UNIX/X11
USE_GMAKE= yes
-USE_LIBTOOL_VER= 13
+USE_REINPLACE= yes
+USE_INC_LIBTOOL_VER=15
ALL_TARGET= without_doc
INSTALLS_SHLIB= yes
@@ -33,6 +34,15 @@ CONFIGURE_ARGS+= --without-x
PLIST_SUB+= X11="@comment "
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|^LIBTOOL[ ]*=.*|LIBTOOL=${LIBTOOL}|' \
+ ${WRKSRC}/xglyph/Makefile.in ${WRKSRC}/lib/type1/Makefile.in \
+ ${WRKSRC}/lib/t1lib/Makefile.in ${WRKSRC}/lib/Makefile.in \
+ ${WRKSRC}/type1afm/Makefile.in ${WRKSRC}/examples/Makefile.in
+
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}