aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/cgit/Makefile8
-rw-r--r--devel/doxygen/Makefile2
-rw-r--r--devel/gdb66/Makefile8
-rw-r--r--devel/glib20/Makefile8
-rw-r--r--devel/glib20/files/patch-ae34
-rw-r--r--devel/libhtp/Makefile11
-rw-r--r--devel/libparserutils/Makefile2
-rw-r--r--devel/py-fusefs/Makefile2
-rw-r--r--devel/styx/Makefile2
9 files changed, 61 insertions, 16 deletions
diff --git a/devel/cgit/Makefile b/devel/cgit/Makefile
index 423cd4bc0977..ad8a1755191e 100644
--- a/devel/cgit/Makefile
+++ b/devel/cgit/Makefile
@@ -33,6 +33,7 @@ SUB_LIST+= PORTNAME=${PORTNAME}
PLIST_SUB+= PORTNAME=${PORTNAME} WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
post-extract:
@${RMDIR} ${WRKSRC}/git
@@ -44,6 +45,11 @@ post-patch:
${WRKSRC}/git/Makefile
@${REINPLACE_CMD} -e 's,/usr,${PREFIX},g' \
-e 's,-Igit,-I.,g' ${WRKSRC}/Makefile
+.if empty(ICONV_LIB)
+ @${REINPLACE_CMD} -e '/NEEDS_LIBICONV = YesPlease/d' \
+ -e '/OLD_ICONV = YesPlease/d' \
+ ${WRKSRC}/git/config.mak.uname
+.endif
post-install:
@${MKDIR} /var/cache/${PORTNAME}
@@ -54,4 +60,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}rc.5.txt ${DOCSDIR}/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/doxygen/Makefile b/devel/doxygen/Makefile
index 465defb99d87..2c307bff58a7 100644
--- a/devel/doxygen/Makefile
+++ b/devel/doxygen/Makefile
@@ -77,7 +77,7 @@ PLIST_FILES+= bin/doxywizard
pre-configure:
@cd ${WRKSRC};for pro in src/*.pro.in addon/doxywizard/doxywizard.pro.in;do \
- ${ECHO} "unix:LIBS += -liconv" >> $$pro; done
+ ${ECHO} "unix:LIBS += ${ICONV_LIB}" >> $$pro; done
@${CHMOD} +x ${WRKSRC}/configure
post-configure:
diff --git a/devel/gdb66/Makefile b/devel/gdb66/Makefile
index c76e578b4692..1d91e5dd5a4d 100644
--- a/devel/gdb66/Makefile
+++ b/devel/gdb66/Makefile
@@ -27,7 +27,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV+= CONFIGURED_M4=m4 CONFIGURED_BISON=byacc
CONFIGURE_ARGS= --program-suffix=${PORTVERSION:S/.//g} \
--enable-target=all \
- --enable-tui --with-libiconv-prefix=${LOCALBASE}
+ --enable-tui
CFLAGS:= ${CFLAGS:C/ +$//} # blanks at EOL creep in sometimes
CFLAGS+= -DRL_NO_COMPAT
EXCLUDE= dejagnu expect readline sim texinfo intl
@@ -38,6 +38,10 @@ MAN1= gdb${VER}.1
.include <bsd.port.options.mk>
+.if empty(ICONV_LIB)
+CONFIGURE_ARGS+= --with-libiconv-prefix=${LOCALBASE}
+.endif
+
.if ${PORT_OPTIONS:MINSIGHT}
PKGNAMESUFFIX= -insight
USE_TK= 84+
@@ -87,7 +91,7 @@ post-patch:
${WRKSRC}/gdb/version.in
@${REINPLACE_CMD} -e 's/^READLINE/#READLINE/' \
-e 's/^readline/#readline/' \
- -e 's,^LIBICONV =.*,LIBICONV=-L${LOCALBASE}/lib -liconv,' \
+ -e 's,^LIBICONV =.*,LIBICONV=-L${LOCALBASE}/lib ${ICONV_LIB},' \
${WRKSRC}/gdb/Makefile.in
${ECHO} 'READLINE = -lreadline' >> ${WRKSRC}/gdb/Makefile.in
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index 50598fcb78bc..4030736d8183 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -29,7 +29,7 @@ USES= gettext gmake iconv pathfix pkgconfig shebangfix
USE_GNOME= ltverhack
USE_PYTHON= 2.5+
USE_PERL5= yes
-CONFIGURE_ARGS= --enable-static --with-libiconv=gnu \
+CONFIGURE_ARGS= --enable-static \
--disable-gtk-doc --with-html-dir=${PREFIX}/share/doc \
--disable-man --without-xml-catalog \
--with-pcre=system \
@@ -54,6 +54,12 @@ CONFIGURE_ARGS+=--disable-dtrace
#CONFIGURE_ARGS+=--enable-dtrace
#.endif
+.if exists(/usr/include/iconv.h) && ${OSVERSION} >= 1000043
+CONFIGURE_ARGS+= --with-libiconv=native
+.else
+CONFIGURE_ARGS+= --with-libiconv=gnu
+.endif
+
.if ${ARCH} == powerpc64
EXTRA_PATCHES= ${FILESDIR}/extra-arch-powerpc64
.endif
diff --git a/devel/glib20/files/patch-ae b/devel/glib20/files/patch-ae
index e62156bf5c34..9396ef32ab24 100644
--- a/devel/glib20/files/patch-ae
+++ b/devel/glib20/files/patch-ae
@@ -1,5 +1,5 @@
---- configure.orig 2013-03-28 02:59:16.000000000 +0000
-+++ configure 2013-03-28 03:00:20.000000000 +0000
+--- configure.orig 2013-08-29 23:29:13.255661322 +0200
++++ configure 2013-08-29 23:48:08.845647995 +0200
@@ -603,6 +603,9 @@
#ifdef HAVE_SYS_TYPES_H
# include <sys/types.h>
@@ -10,7 +10,7 @@
#ifdef HAVE_SYS_STAT_H
# include <sys/stat.h>
#endif
-@@ -5699,7 +5702,7 @@
+@@ -5778,7 +5781,7 @@
fi
GLIB_RUNTIME_LIBDIR="$with_runtime_libdir"
@@ -19,7 +19,31 @@
if test "x$with_runtime_libdir" != "x"; then
-@@ -23089,7 +23092,7 @@
+@@ -7444,13 +7447,12 @@
+
+ ;;
+ native)
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for iconv_open in -liconv" >&5
+-$as_echo_n "checking for iconv_open in -liconv... " >&6; }
++ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for iconv_open" >&5
++$as_echo_n "checking for iconv_open... " >&6; }
+ if ${ac_cv_lib_iconv_iconv_open+:} false; then :
+ $as_echo_n "(cached) " >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-liconv $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -8648,6 +8650,7 @@
+ ;;
+ native)
+
++ICONV_LIBS=""
+ $as_echo "#define USE_LIBICONV_NATIVE 1" >>confdefs.h
+
+ ;;
+@@ -23201,7 +23204,7 @@
fi
done
@@ -28,7 +52,7 @@
do :
as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"
-@@ -26629,10 +26632,10 @@
+@@ -26741,10 +26744,10 @@
# b) FreeBSD doesn't do this either.
#
case $host in
diff --git a/devel/libhtp/Makefile b/devel/libhtp/Makefile
index dff6c82ebf33..bf619530164f 100644
--- a/devel/libhtp/Makefile
+++ b/devel/libhtp/Makefile
@@ -18,12 +18,17 @@ ACLOCAL_ARGS= -Im4
USE_LDCONFIG= yes
USES= pkgconfig pathfix iconv
-CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE}
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib \
- -liconv
+ ${ICONV_LIB}
+
+.include <bsd.port.pre.mk>
+
+.if empty(ICONV_LIB)
+CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE}
+.endif
pre-configure:
@${REINPLACE_CMD} -Ee 's,^(pkgconfigdir = ).*,\1$$(exec_prefix)/libdata/pkgconfig,' ${WRKSRC}/Makefile.am
@cd ${WRKSRC} && ${SH} ./autogen.sh
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/libparserutils/Makefile b/devel/libparserutils/Makefile
index 734b07d391e6..f862226d797a 100644
--- a/devel/libparserutils/Makefile
+++ b/devel/libparserutils/Makefile
@@ -25,7 +25,7 @@ OPTIONS_DEFAULT= ICONV STATIC TEST DOXYGEN
.if ${PORT_OPTIONS:MICONV}
CFLAGS+= -DWITH_ICONV_FILTER
-LDFLAGS+= -liconv
+LDFLAGS+= ${ICONV_LIB}
.endif
.if ${PORT_OPTIONS:MSTATIC}
diff --git a/devel/py-fusefs/Makefile b/devel/py-fusefs/Makefile
index 894449307cbd..2f3f32b388fa 100644
--- a/devel/py-fusefs/Makefile
+++ b/devel/py-fusefs/Makefile
@@ -24,7 +24,7 @@ DOCSDIR?= ${PREFIX}/share/doc/py-fusefs
EXAMPLESDIR?= ${PREFIX}/share/examples/py-fusefs
post-patch:
- @${REINPLACE_CMD} -e '/libs =/s|$$| + " -liconv"|'\
+ @${REINPLACE_CMD} -e '/libs =/s|$$| + " ${ICONV_LIB}"|'\
${WRKSRC}/setup.py
post-install:
diff --git a/devel/styx/Makefile b/devel/styx/Makefile
index 3e97bf4a9329..baab2e511a99 100644
--- a/devel/styx/Makefile
+++ b/devel/styx/Makefile
@@ -20,7 +20,7 @@ USES= iconv
USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -liconv
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
CONFIGURE_ARGS= --includedir=${PREFIX}/include/${PORTNAME}
USE_LDCONFIG= yes